Bug 495353 - Fedora-11-Snap1-x86_64-Live-KDE "SELinux is preventing loadkeys..." when installing to hard disk
Fedora-11-Snap1-x86_64-Live-KDE "SELinux is preventing loadkeys..." when inst...
Status: CLOSED DUPLICATE of bug 484370
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 06:08 EDT by Markku Kolkka
Modified: 2013-01-10 00:09 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 14:51:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First SElinux alert (4.21 KB, text/plain)
2009-04-12 06:08 EDT, Markku Kolkka
no flags Details
Second SElinux alert (2.99 KB, text/plain)
2009-04-12 06:09 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2009-04-12 06:08:45 EDT
Created attachment 339221 [details]
First SElinux alert

Description of problem:
After selecting the keyboard layout in the installer, SEtroubleshoot shows two errors: "SELinux is preventing the loadkeys from using potentially mislabeled files (Documents)." and "SELinux is preventing loadkeys (loadkeys_t) "write" to /home/liveuser/.xsession-errors (user_home_t). "

Version-Release number of selected component (if applicable):
3.6.12-2.fc11

How reproducible:
not tested

Steps to Reproduce:
1. Boot with Fedora-11-Snap1-x86_64-Live-KDE
2. Start "Install to Hard Drive"
3. Choose a keyboard other than English
  
Actual results:
SElinux denials displayed by SEtrubleshoot

Expected results:
Installation proceeds without warnings

Additional info:
Comment 1 Markku Kolkka 2009-04-12 06:09:36 EDT
Created attachment 339222 [details]
Second SElinux alert
Comment 2 Daniel Walsh 2009-04-13 08:38:00 EDT
THe .xsession-errors directory is mislabeled.  It should be xdm_home_t.

Kde is leaking a file descriptor to /dev/mapper/control to loadkeys as well as a open file descriptor to /home/livecd/Document.

All of these can be ignored.

Setroubleshoot shoud probably not be installed on a livecd, since there is not much that a user can do to fix these problems.
Comment 3 Rex Dieter 2009-04-13 08:49:37 EDT

*** This bug has been marked as a duplicate of bug 484370 ***
Comment 4 Daniel Walsh 2009-04-13 09:44:11 EDT
Well this is not quite a duplicate since it also has .xsession-errors mislabeled in the livecd image.
Comment 5 Rex Dieter 2009-04-13 09:47:37 EDT
ok, there's 2 bugs here, let's focus this one on .xsession-errors mislabeling, which certainly isn't a kde issue then.  Where to assign that?  livecd-tools?
Comment 6 Rex Dieter 2009-04-13 09:50:13 EDT
-> LiveCD for now.
Comment 7 Jeremy Katz 2009-04-13 13:08:08 EDT
.xsession-errors will just get created by the first thing which outputs to it -- kdm possibly?  It's not created by the livecd; we just use adduser to create the user's homedir.
Comment 8 Rex Dieter 2009-04-13 13:16:25 EDT
ok, then it *is* a dup (and same cause).  ??
Comment 9 Daniel Walsh 2009-04-13 13:59:14 EDT
Well if kde was running as xdm_t (Which it should, it should have created the file with the correct context xdm_home_t.)  If something else created like a process running as the user, then it will get labelled incorrectly.  xdm seems to create the file itself before execing the user shell, If kde execs the user shell and this creates it, it could be a problem.
Comment 10 Rex Dieter 2009-05-26 14:51:00 EDT
A fixed kdelibs landed
* Sat Apr 18 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.2-6
- squash leaky file descriptors in kdeinit (kde#180785,rhbz#484370)

So, let's close this, unless there's new evidence of it still being present.

*** This bug has been marked as a duplicate of bug 484370 ***

Note You need to log in before you can comment on or make changes to this bug.