This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 495356 - Unhandled exception at the end of partitioning
Unhandled exception at the end of partitioning
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
anaconda_trace_hash:74cb3903b853cca66...
:
: 496377 (view as bug list)
Depends On:
Blocks: AnacondaStorage
  Show dependency treegraph
 
Reported: 2009-04-12 06:17 EDT by Markku Kolkka
Modified: 2010-01-15 09:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-15 09:42:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (214.53 KB, text/plain)
2009-04-12 06:17 EDT, Markku Kolkka
no flags Details
Anaconda traceback (296.17 KB, text/plain)
2009-05-22 02:22 EDT, Markku Kolkka
no flags Details
Anaconda traceback from Fedora 11 install on Dell Dimension 9200 (240.46 KB, application/octet-stream)
2009-06-10 16:31 EDT, Vincent Rivellino
no flags Details
Yet another Anaconda traceback (316.60 KB, text/plain)
2009-06-25 16:09 EDT, Markku Kolkka
no flags Details
Unhandled exception dump by Anaconda (396.55 KB, text/plain)
2009-09-13 12:23 EDT, Francisco S. Wechsler
no flags Details

  None (edit)
Description Markku Kolkka 2009-04-12 06:17:20 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 282, in setup
    raise FormatSetupError("invalid device specification")
  File "/usr/lib/anaconda/storage/devices.py", line 530, in setup
    parent.format.setup()
  File "/usr/lib/anaconda/storage/devices.py", line 263, in setupParents
    parent.setup()
  File "/usr/lib/anaconda/storage/devices.py", line 1656, in setup
    self.setupParents()
  File "/usr/lib/anaconda/storage/devices.py", line 1959, in setup
    self.vg.setup()
  File "/usr/lib/anaconda/storage/deviceaction.py", line 322, in execute
    self._device.setup()
  File "/usr/lib/anaconda/storage/devicetree.py", line 658, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 229, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
FormatSetupError: invalid device specification
Comment 1 Markku Kolkka 2009-04-12 06:17:31 EDT
Created attachment 339226 [details]
Attached traceback automatically from anaconda.
Comment 2 Markku Kolkka 2009-04-12 06:32:49 EDT
This report is from F11-Snap1-x86_64-KDE-Live
Comment 3 Markku Kolkka 2009-04-13 16:29:20 EDT
Hardware configuration: http://www.smolts.org/client/show/?uuid=pub_b6451a8c-fbe5-48d9-a445-cb84f73a46ad
Comment 4 Hans de Goede 2009-04-16 03:34:33 EDT
I've spend hours trying to reproduce this, but I failed, also it makes no
sense, that traceback should not happen. At first I suspected a timing issue, but that is not possible either. Quite a few fixes have gone in, can you please try to reproduce this doing a net install with boot.iso from current rawhide ?
Comment 5 Markku Kolkka 2009-04-16 10:11:29 EDT
i tried today's (2009-04-16) rawhide boot.iso, but I hit https://bugzilla.redhat.com/show_bug.cgi?id=495687 before getting to the same stage where this exception happened.
Comment 6 Hans de Goede 2009-04-16 14:36:38 EDT
Thanks for testing!

Can you please retry with tomorrows rawhide, which should have
anaconda-11.5.0.45-1, which according to bug 495687, fixes bug 495687.

Thanks! and sorry for all the troubles.
Comment 7 Hans de Goede 2009-04-18 08:47:01 EDT
*** Bug 496377 has been marked as a duplicate of this bug. ***
Comment 8 Markku Kolkka 2009-04-18 11:35:34 EDT
(In reply to comment #6)
As you can see from #496377, the problem remains in anaconda 11.5.0.45
Comment 9 Hans de Goede 2009-05-06 07:22:52 EDT
I'm afraid I'm completely clueless as to what is happening here, if I've tried to
reproduce this but failed, I've also carefully studied the code and I can find no code path's where this could happen.

Can you please retest with preview1 ?
Comment 10 Markku Kolkka 2009-05-12 16:52:51 EDT
(In reply to comment #9)
> Can you please retest with preview1 ?  
Re-tested with boot.iso from 2009-05-11 with anaconda 11.5.0.51, see https://bugzilla.redhat.com/attachment.cgi?id=343663 for the crash dump.
Comment 11 Markku Kolkka 2009-05-22 02:22:51 EDT
Created attachment 345061 [details]
Anaconda traceback 

Tested again with fresh boot.iso/anaconda 11.5.0.54, no change in results
Comment 12 Bug Zapper 2009-06-09 09:41:07 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Vincent Rivellino 2009-06-10 16:31:43 EDT
Created attachment 347285 [details]
Anaconda traceback from Fedora 11 install on Dell Dimension 9200

Looks like I ran into this bug when trying to install Fedora 11 on my Dell Dimension 9200.  I have attached a traceback.

FYI - I was doing a custom partition layout with LVM, so I could maintain my /home partition.
Comment 14 Markku Kolkka 2009-06-25 16:09:24 EDT
Created attachment 349459 [details]
Yet another Anaconda traceback

As the attached dump shows, the bug remains unchanged in F11 final release. At least it crashes before anything gets written on the disk, and the existing F8 installation remains untouched.
Comment 15 Francisco S. Wechsler 2009-09-13 12:23:35 EDT
Created attachment 360846 [details]
Unhandled exception dump by Anaconda
Comment 16 Francisco S. Wechsler 2009-09-13 13:23:16 EDT
A similar - if not identical bug - occurs when I try to install F11 on a Dell Latitude D520 Laptop (i32), having 512 MB RAM.  My computer was running F9 alone with no visible problems. I needed to make it dual-boot, so I reformatted the HD with fdisk, reserving 31 GB for Windows, which was then installed normally.

Then I downloaded an F11 DVD iso image. Checksum proved OK. Burned image to DVD. Booted with this DVD. Installation media check OK. Memtest reported no RAM errors.

Here is the installation sequence:

- Chose to install with basic video driver.

- Chose English, Brazilian (ABNT2) keyboard, computer name, time zone and root password.

- Created the following custom partition layout:
  /dev/sda1 ntfs 31000 MB (already there, with 31000 MB dedicated to Windows XP);
  /dev/sda2 ext3 80 MB, mounting point: /boot;
  /dev/sda3 swap 1002 MB;
  /dev/sda4 Extended 25148 MB;
     /dev/sda5 ext4 25148, mounting point: /.

(The above partitions used up all the disk space.)
  
- Asked to format all of the above, excepting /dev/sda1.

- Asked to write changes to disk.

- Chose boot loader password.

- Accepted system's choice to install bootloader on /dev/sda5.

- After proceeding, I got an unhandled exception message and saved its dump (see attachment #5 [details]).

I then tried to reboot the DVD and did not get the message this time, managing to get past the partition point. Then I chose to install the default Office and Poductivity packages from the installation repo and chose to customize them later. F11 checked the dependencies, proceeded to install the packages and the installation went OK until selinux-policy-3.6.12-39fc11.noarch.rpm. F11 said it could not open this package, due to a missing file, a corrupt package or corrupt media and told me to verify my installation source.

I chose to reboot and tried to install from an existing system, proceeded as before until the partition point. An unhandled exception occurred again.

I rebooted, tried to reinstall, choosing the default partition scheme proposed by F11. Again an unhandled exception occurred.

Needless to say, the MBR has been damaged, and no boot from the HD is now possible. I am considering going back to F9, but I would like to install F11, if possible.

All help will be appreciated.

Best wishes,

Francisco S. Wechsler
Comment 17 Hans de Goede 2010-01-06 16:41:37 EST
Markku,

Have you tried installing Fedora 12 on the system in question yet ? And does that
work ? If it does not work, could you please attach the log files under /tmp (use scp from tty2) when the F-12 installer crashes ?

Thanks,

Hans
Comment 18 Francisco S. Wechsler 2010-01-08 00:46:35 EST
Although the question is directed to Markku, let me elaborate a bit further. Since my last e-mail, I succeeded in installing Fedora 11 by using the NetInstall CD. No problems were detected during the installation.

I have not tried installing Fedora 12 yet, but I intend to.

Hope this will help you. Best wishes,

Francisco S. Wechsler
Comment 19 Markku Kolkka 2010-01-15 09:42:10 EST
(In reply to comment #17)
> Markku,
> 
> Have you tried installing Fedora 12 on the system in question yet ? And does
> that work ?

F12 installation doesn't crash with this bug. I'm setting status as CLOSED/CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.