Bug 495404 - Exception while editing a partition
Exception while editing a partition
Status: CLOSED DUPLICATE of bug 495288
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-04-12 15:30 EDT by Bruno Wolff III
Modified: 2009-04-14 09:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-14 09:33:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Saved traceback (47.93 KB, text/plain)
2009-04-13 22:19 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2009-04-12 15:30:20 EDT
Description of problem:
I clicked on edit and then selected a partition that had been set up to be part of a raid array in a failed disk setup using the beta install image. The result was an exception. I don't know if the partition was created in some odd way because of the previous failure. Afterwards I went back and deleted the partition instead of editing it and that seemed to work.

Version-Release number of selected component (if applicable):
The system was originally booted with an i386 beta install image and the dvd pulled out once the boot was in process so that I would be given the option to do a hard drive install. The install.img on the hard drive was from the 2009-04-11 rawhide (and also i386).

How reproducible:
I don't know. I wasn't going to spend a lot of time trying to reproduce it right now. However it would probably be worth doing a quick test of editing partitions when doing a custom layout once the dbus issue is fixed.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Chris Lumens 2009-04-13 10:44:13 EDT
Can you please attach the complete traceback to this bug report so we can investigate it?
Comment 2 Bruno Wolff III 2009-04-13 11:05:07 EDT
I am short on time right now and have one machine I need to get working soon.
I have another I am not in a hurry to get installed and will retest using a current boot.iso once the dbus issue is fixed and I have a bit of time.
I think there probably is a problem related to raid and/or encryption in custom disk layouts. But because I am mixing install images (trying to work around the dbus
issue) I don't know that the problem is really in the latest version.
Comment 3 Bruno Wolff III 2009-04-13 22:19:30 EDT
Created attachment 339405 [details]
Saved traceback

I retested this with livecd-fedora-livecd-testday-20090414-i386.iso and still got the error. I selected a custom layout, advanced to the next screen and tried to edit a partition and generated the attached traceback.
Comment 4 James Laska 2009-04-14 08:17:11 EDT
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 334, in createPreExistFSOptionSection
    if not formatcb.get_active() and not origfs.migrate:
  File "/usr/lib/anaconda/iw/raid_dialog_gui.py", line 507, in __init__
    (row, self.fsoptionsDict) = createPreExistFSOptionSection(origrequest, maintable, row, self.mountCombo, self.storage, luksdev=luksdev)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1076, in editRaidArray
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1062, in editCB
AttributeError: 'NoneType' object has no attribute 'get_active'
Comment 5 Chris Lumens 2009-04-14 09:33:35 EDT

*** This bug has been marked as a duplicate of bug 495288 ***

Note You need to log in before you can comment on or make changes to this bug.