Bug 495538 - Cannot read/play Audio CDs
Cannot read/play Audio CDs
Status: CLOSED DUPLICATE of bug 458036
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 14:22 EDT by Tomas Toth
Modified: 2009-05-29 07:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 07:54:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reports (Tar-Gzip) (20.47 KB, application/x-compressed-tar)
2009-04-13 14:22 EDT, Tomas Toth
no flags Details
/var/log/dmesg from booting 2.6.29.1-30 (36.10 KB, text/plain)
2009-04-17 14:34 EDT, Tomas Toth
no flags Details
output of the 'lspci -vnn' command (for 2.6.29.1-30) (12.77 KB, text/plain)
2009-04-17 14:36 EDT, Tomas Toth
no flags Details
/var/log/messages from booting 2.6.29.1-30 (63.11 KB, text/plain)
2009-04-17 15:46 EDT, Tomas Toth
no flags Details

  None (edit)
Description Tomas Toth 2009-04-13 14:22:10 EDT
Created attachment 339349 [details]
Reports (Tar-Gzip)

Description of problem:
After inserting an Audio CD into the drive nothing happens, no new device is detected. 
Moreover there are kernel errors in /var/log/messages:
Apr 13 18:21:10 localhost kernel: end_request: I/O error, dev sr0, sector 0
Apr 13 18:21:10 localhost kernel: Buffer I/O error on device sr0, logical block 0
Apr 13 18:21:10 localhost kernel: Buffer I/O error on device sr0, logical block 1
Apr 13 18:21:10 localhost kernel: Buffer I/O error on device sr0, logical block 2
Apr 13 18:21:10 localhost kernel: Buffer I/O error on device sr0, logical block 3
Apr 13 18:21:10 localhost kernel: end_request: I/O error, dev sr0, sector 0
Apr 13 18:21:10 localhost kernel: Buffer I/O error on device sr0, logical block 0

DVDs and data CDs work fine.


Version-Release number of selected component (if applicable):
# uname -a
Linux omega 2.6.27.21-170.2.56.fc10.x86_64 #1 SMP Mon Mar 23 23:08:10 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

The same issue exist with Fedora-11 Beta (Updated) - Rawhide:
# cat uname.f10.92
Linux localhost.localdomain 2.6.29-0.258.2.3.rc8.git2.fc11.i586 #1 SMP Tue Mar 24 18:37:23 EDT 2009 i686 athlon i386 GNU/Linux

For Fedora-11 testing use the KDE Live running from USB flash drive.


How reproducible:
Always. Insert an audio CD into the drive.

  
Actual results:
Nothing happens - unable to play the CD, errors in /var/log/messages.

Expected results:
New device get detected and I am able to play the CD.


Additional info:
I found a similar bug #485551 but it seems to be connected to SATA drives. From lshw it seems that my drive is PATA, that is why I decided to create a new bug. I am not an expert so feel free to correct me.

Attached please found reports.tgz (Tar-Gzip) which includes:
  /var/log/messages
  output of lscpi -vnn 
for both Fedora-10 (.f10) and Fedora-11 Beta / Rawhide (.f10.92)
and output of lshw for Fedora-10.
Comment 1 Chuck Ebbert 2009-04-15 16:09:20 EDT
There should be a bunch of messages before those, probably from the ata layer. Would you post any that you find?
Comment 2 Tomas Toth 2009-04-15 18:41:04 EDT
There are no such messages, unfortunately. I redone the tests. I waited several minutes after inserting the CD into the drive and after opening the drive's door, but there is no change:
Fedora-10:
Linux omega 2.6.27.21-170.2.56.fc10.x86_64 #1 SMP Mon Mar 23 23:08:10 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Test starts at: Apr 15 22:26:xx
/var/log/messages:
Apr 15 18:52:14 localhost ntpd[2268]: kernel time sync status change 0001
Apr 15 19:43:28 localhost ntpd[2268]: kernel time sync status change 4001
Apr 15 21:08:53 localhost ntpd[2268]: kernel time sync status change 0001
Apr 15 21:09:40 localhost dhclient: DHCPREQUEST on eth0 to 213.46.172.164 port 67
Apr 15 21:09:40 localhost dhclient: DHCPACK from 213.46.172.164
Apr 15 21:09:40 localhost dhclient: bound to 86.49.105.117 -- renewal in 5887 seconds.
Apr 15 22:17:09 localhost ntpd[2268]: kernel time sync status change 4001
Apr 15 22:26:17 localhost kernel: end_request: I/O error, dev sr0, sector 0
Apr 15 22:26:17 localhost kernel: Buffer I/O error on device sr0, logical block 0
Apr 15 22:26:17 localhost kernel: Buffer I/O error on device sr0, logical block 1
Apr 15 22:26:17 localhost kernel: Buffer I/O error on device sr0, logical block 2
Apr 15 22:26:17 localhost kernel: Buffer I/O error on device sr0, logical block 3
Apr 15 22:26:17 localhost kernel: end_request: I/O error, dev sr0, sector 0
Apr 15 22:26:17 localhost kernel: Buffer I/O error on device sr0, logical block 0


Fedora-11-Beta/Rawhide:
Linux localhost.localdomain 2.6.29-0.258.2.3.rc8.git2.fc11.x86_64 #1 SMP Tue Mar 24 18:39:53 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Test starts at: Apr 15 21:55:xx
/var/log/messages:
Apr 15 21:50:49 localhost pulseaudio[3805]: pid.c: Daemon already running.
Apr 15 21:52:35 localhost NetworkManager: <info>  (wlan0): device state change: 3 -> 2
Apr 15 21:52:35 localhost NetworkManager: <info>  (wlan0): deactivating device (reason: 0).
Apr 15 21:52:36 localhost NetworkManager: <info>  Policy set 'Auto eth0' (eth0) as default for routing and DNS.
Apr 15 21:52:36 localhost NetworkManager: <info>  (wlan0): taking down device.
Apr 15 21:52:36 localhost dbus: Rejected send message, 3 matched rules; type="method_return", sender=":1.9" (uid=0 pid=3304 comm="NetworkManager --pid-file=/var/run/NetworkManager/") interface="(unset)" member="(unset)" error name="(unset)" requested_reply=0 destination=":1.40" (uid=500 pid=3772 comm="/usr/bin/nm-applet --sm-disable "))
Apr 15 21:55:26 localhost kernel: sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Apr 15 21:55:26 localhost kernel: sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Apr 15 21:55:26 localhost kernel: ILI
Apr 15 21:55:26 localhost kernel: sr 4:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Apr 15 21:55:26 localhost kernel: end_request: I/O error, dev sr0, sector 0
Apr 15 21:55:26 localhost kernel: Buffer I/O error on device sr0, logical block 0
Apr 15 21:55:26 localhost kernel: Buffer I/O error on device sr0, logical block 1
Apr 15 21:55:26 localhost kernel: Buffer I/O error on device sr0, logical block 2
Apr 15 21:55:26 localhost kernel: Buffer I/O error on device sr0, logical block 3
Apr 15 21:55:26 localhost kernel: sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Apr 15 21:55:26 localhost kernel: sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Apr 15 21:55:26 localhost kernel: ILI
Apr 15 21:55:26 localhost kernel: sr 4:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Apr 15 21:55:26 localhost kernel: end_request: I/O error, dev sr0, sector 0
Apr 15 21:55:26 localhost kernel: Buffer I/O error on device sr0, logical block 0
Apr 15 21:59:20 localhost kernel: BUG: MAX_LOCKDEP_ENTRIES too low!
Apr 15 21:59:20 localhost kernel: turning off the locking correctness validator.


The only change are the last two lines with:
  Apr 15 21:59:20 localhost kernel: BUG: MAX_LOCKDEP_ENTRIES too low!
  Apr 15 21:59:20 localhost kernel: turning off the locking correctness
   validator.
but I have no idea whether they can be related to the audio CD issue.
Comment 3 Chuck Ebbert 2009-04-16 22:23:55 EDT
I can't reproduce this at all. Can you try 2.6.29.1-30.fc10 from the updates-testing repository? If that doesn't work, please post (as separate uncompressed attachments; it's really difficult to deal with attached tarballs):

1.  /var/log/dmesg from booting 2.6.29.1-30
2.  output of the 'lspci -vnn' command
Comment 4 Tomas Toth 2009-04-17 14:34:38 EDT
Created attachment 340063 [details]
/var/log/dmesg from booting 2.6.29.1-30
Comment 5 Tomas Toth 2009-04-17 14:36:19 EDT
Created attachment 340065 [details]
output of the 'lspci -vnn' command (for 2.6.29.1-30)
Comment 6 Tomas Toth 2009-04-17 14:44:23 EDT
The issue still persists with kernel 2.6.29.1-30.fc10 from the
updates-testing repository.

uname -a:
Linux omega 2.6.29.1-30.fc10.x86_64 #1 SMP Tue Apr 14 10:56:10 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

/var/log/messages The test starts at Apr 17 20:16:xx:
 . . . .
Apr 17 20:03:57 localhost NetworkManager: <info>  (wlan0): device state change: 3 -> 2
Apr 17 20:03:57 localhost NetworkManager: <info>  (wlan0): deactivating device (reason: 0).
Apr 17 20:03:57 localhost NetworkManager: <info>  Policy set 'System eth0' (eth0) as default for routing and DNS.
Apr 17 20:03:57 localhost NetworkManager: <info>  (wlan0): taking down device.
Apr 17 20:04:52 localhost ntpd[2419]: synchronized to 130.236.254.17, stratum 1
Apr 17 20:15:01 localhost kernel: CE: hpet increasing min_delta_ns to 15000 nsec
Apr 17 20:16:24 localhost kernel: sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Apr 17 20:16:24 localhost kernel: sr 3:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Apr 17 20:16:24 localhost kernel: ILI
Apr 17 20:16:24 localhost kernel: sr 3:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Apr 17 20:16:24 localhost kernel: end_request: I/O error, dev sr0, sector 0
Apr 17 20:16:24 localhost kernel: Buffer I/O error on device sr0, logical block 0
Apr 17 20:16:24 localhost kernel: Buffer I/O error on device sr0, logical block 1
Apr 17 20:16:24 localhost kernel: Buffer I/O error on device sr0, logical block 2
Apr 17 20:16:24 localhost kernel: Buffer I/O error on device sr0, logical block 3
Apr 17 20:16:24 localhost kernel: sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Apr 17 20:16:24 localhost kernel: sr 3:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Apr 17 20:16:24 localhost kernel: ILI
Apr 17 20:16:24 localhost kernel: sr 3:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Apr 17 20:16:24 localhost kernel: end_request: I/O error, dev sr0, sector 0
Apr 17 20:16:24 localhost kernel: Buffer I/O error on device sr0, logical block 0

There are no more messages in the file for several minutes following the test.

Also please find the requested logs at Comment #4 and #5.
Comment 7 Tomas Toth 2009-04-17 15:46:53 EDT
Created attachment 340079 [details]
/var/log/messages  from booting 2.6.29.1-30

Attached also find the  /var/log/messages  from the point of booting the 2.6.29.1-30 kernel.
The test started - the audio CD was inserted into the drive at "Apr 17 20:16:xx".
Comment 8 Karl S. 2009-04-23 01:06:53 EDT
I'm having exactly the same symptoms, with two different drives on the same system.  DVD-ROMs work fine, but audio CDs cause the I/O errors as above.  I'm using pretty vanilla Fedora 10:  kernel-2.6.27.5-117.fc10.i686

Here is the pertinent section from dmesg ("driver needs updating" message is a harmless warning, right?):

Driver 'sd' needs updating - please use bus_type methods
Driver 'sr' needs updating - please use bus_type methods
ata_piix 0000:00:1f.1: version 2.12
ata_piix 0000:00:1f.1: PCI INT A -> GSI 22 (level, low) -> IRQ 22
ata_piix 0000:00:1f.1: setting latency timer to 64
scsi0 : ata_piix
scsi1 : ata_piix
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xffa8 irq 15
ata1.00: ATAPI: DVD-RW IDE1108, VER B018, max UDMA/66
ata1.01: ATAPI: LITE-ON COMBO SOHC-5236V, R$0C, max UDMA/44
ata1.00: limited to UDMA/33 due to 40-wire cable
ata1.01: limited to UDMA/33 due to 40-wire cable
ata1.00: configured for UDMA/33
ata1.01: configured for UDMA/33
scsi 0:0:0:0: CD-ROM            DVDRW    IDE1108          B018 PQ: 0 ANSI: 5
sr0: scsi3-mmc drive: 1x/40x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 0:0:0:0: Attached scsi CD-ROM sr0
sr 0:0:0:0: Attached scsi generic sg0 type 5
scsi 0:0:1:0: CD-ROM            LITE-ON  COMBO SOHC-5236V R$0C PQ: 0 ANSI: 5
sr1: scsi3-mmc drive: 0x/52x writer cd/rw xa/form2 cdda tray
sr 0:0:1:0: Attached scsi CD-ROM sr1
sr 0:0:1:0: Attached scsi generic sg1 type 5

[...]

end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
Buffer I/O error on device sr0, logical block 1
Buffer I/O error on device sr0, logical block 2
Buffer I/O error on device sr0, logical block 3
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
end_request: I/O error, dev sr1, sector 0
Buffer I/O error on device sr1, logical block 0
Buffer I/O error on device sr1, logical block 1
Buffer I/O error on device sr1, logical block 2
Buffer I/O error on device sr1, logical block 3
Comment 9 Daniel Qarras 2009-05-05 16:47:28 EDT
FWIW, I am seeing this, too, with audio CDs that seem to be in perfect condition by visual inspection. I have a dual boot laptop and under WinXP my audio CDs work perfectly.

usb 4-2.1: input irq status -75  received
sr 0:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 0:0:1:0: [sr0] Sense Key : Illegal Request [current] 
Info fld=0x0
sr 0:0:1:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0
__ratelimit: 4 callbacks suppressed
Buffer I/O error on device sr0, logical block 0
Buffer I/O error on device sr0, logical block 1
Buffer I/O error on device sr0, logical block 2
Buffer I/O error on device sr0, logical block 3
Buffer I/O error on device sr0, logical block 4
Buffer I/O error on device sr0, logical block 5
Buffer I/O error on device sr0, logical block 6
Buffer I/O error on device sr0, logical block 7
sr 0:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 0:0:1:0: [sr0] Sense Key : Illegal Request [current] 
Info fld=0x0
sr 0:0:1:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
Buffer I/O error on device sr0, logical block 1
sr 0:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 0:0:1:0: [sr0] Sense Key : Illegal Request [current] 
Info fld=0x0
sr 0:0:1:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0
sr 0:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 0:0:1:0: [sr0] Sense Key : Illegal Request [current] 
Info fld=0x0
sr 0:0:1:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0
sr 0:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 0:0:1:0: [sr0] Sense Key : Illegal Request [current] 
Info fld=0x1
sr 0:0:1:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 4
Comment 10 Tomas Toth 2009-05-06 12:56:01 EDT
FYI: There is no change with kernel 2.6.29.2-52.fc10.x86_64 from the
updates-testing repository, the issue still persists.
There is no significant difference in the logs. I am ready upload them on request.
Comment 11 Chuck Ebbert 2009-05-07 01:17:21 EDT
(In reply to comment #6)
Apr 17 20:16:24 localhost kernel: ILI
Apr 17 20:16:24 localhost kernel: sr 3:0:0:0: [sr0] Add. Sense: Illegal mode
for this track

ILI means "incorrect block length requested"
Comment 12 Daniel Qarras 2009-05-24 05:32:12 EDT
I now tested 2.6.30-rc7 and saw this:

sr 0:0:1:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 0:0:1:0: [sr0] Sense Key : 0x5 [current] 
Info fld=0x0
sr 0:0:1:0: [sr0] ASC=0x64 ASCQ=0x0
end_request: I/O error, dev sr0, sector 0
__ratelimit: 4 callbacks suppressed
Buffer I/O error on device sr0, logical block 0
Buffer I/O error on device sr0, logical block 1
Buffer I/O error on device sr0, logical block 2
Buffer I/O error on device sr0, logical block 3
sr 0:0:1:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 0:0:1:0: [sr0] Sense Key : 0x5 [current] 
Info fld=0x0
sr 0:0:1:0: [sr0] ASC=0x64 ASCQ=0x0
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
sr 0:0:1:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 0:0:1:0: [sr0] Sense Key : 0x5 [current] 
Info fld=0x0
sr 0:0:1:0: [sr0] ASC=0x64 ASCQ=0x0
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
sr 0:0:1:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 0:0:1:0: [sr0] Sense Key : 0x5 [current] 
Info fld=0x0
sr 0:0:1:0: [sr0] ASC=0x64 ASCQ=0x0
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0

Would it be recommended to report this upstream? Or does this look more like a feature than a bug?

Thanks.
Comment 13 Mary Ellen Foster 2009-05-28 18:00:23 EDT
Also an issue with current rawhide (i.e., Fedora 11-to-be)
Comment 14 Kevin Kofler 2009-05-29 07:54:47 EDT

*** This bug has been marked as a duplicate of bug 458036 ***

Note You need to log in before you can comment on or make changes to this bug.