Bug 458036 - kernel I/O errors on audio CDs (KSCD won't play CDs)
kernel I/O errors on audio CDs (KSCD won't play CDs)
Status: CLOSED DUPLICATE of bug 513495
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 495538 497716 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 04:42 EDT by Marc
Modified: 2009-10-26 05:31 EDT (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 05:31:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I/O Error log (9.93 KB, application/vnd.oasis.opendocument.text)
2008-08-07 03:54 EDT, Marc
no flags Details
I/O Log 11 August 2008 (12.42 KB, application/vnd.oasis.opendocument.text)
2008-08-12 04:26 EDT, Marc
no flags Details
Some improvement in KsCD and Kaffeine (32.20 KB, application/vnd.oasis.opendocument.text)
2008-10-23 04:20 EDT, Marc
no flags Details
KsCD log file F11 July 2009 (32.37 KB, application/vnd.oasis.opendocument.text)
2009-07-16 04:07 EDT, Marc
no flags Details
KsCD log file 27 July 2009 (11.51 KB, application/vnd.oasis.opendocument.text)
2009-07-27 04:09 EDT, Marc
no flags Details
Fedora 12 Alpha /var/log/messages (73.61 KB, application/octet-stream)
2009-08-29 16:31 EDT, Tomas Toth
no flags Details
Fedora 12 Alpha dmesg (48.86 KB, application/octet-stream)
2009-08-29 16:33 EDT, Tomas Toth
no flags Details

  None (edit)
Description Marc 2008-08-06 04:42:56 EDT
Description of problem:

Load music CD and select KSCD from program menu. Select digital play back from extras menu as usual (F8, F9), and appropriate drive.

Version-Release number of selected component (if applicable):

Latest Fedora 10 Alpha ISO downloaded and installed on the 5th August 2008
(from Chemnitz mirror).

How reproducible:

Each time I try to play a music CD

Steps to Reproduce:
1. Load music CD, select KSCD, select play CD, then nothing happens.
2. Repeat step 1.
3. Repeat step 2.
  
Actual results:

CD does not play.

Expected results:

Expect CD to play as with F8 and F9.

Additional info:
Comment 1 Kevin Kofler 2008-08-06 06:51:37 EDT
Hmmm, is this also broken with KDE 4.1 on F9?
Comment 2 Marc 2008-08-07 03:54:52 EDT
Created attachment 313668 [details]
I/O Error log
Comment 3 Marc 2008-08-07 04:00:02 EDT
(In reply to comment #1)
> Hmmm, is this also broken with KDE 4.1 on F9?

I've not tried KDE 4.1 on F9 yet.  However, Kaffeine also does not work with audio CDs (Bug report 458034).  Data CDs do work, as they mount and folders can be opened and files copied to the hard drive.

I've added an excerpt from the log as an attachment, which shows the data CD mounting and unmounting, but shows I/O errors with the audio CD and KsCD.
Comment 4 Kevin Kofler 2008-08-07 04:09:04 EDT
From the log, it looks like the kernel doesn't like your audio CD, not a KDE issue at all.
Comment 5 Marc 2008-08-07 04:27:14 EDT
The kernel installed from the DVD ISO for the F10 Alpha (5th August 2008 download) is kernel-2.6.27-0.166.rc0.git8.fc10.i686.rpm.  I've seen an updated kernel on the Chemnitz mirror (kernel-2.6.27-0.226.rc1.git5.fc10.i686.rpm), which I've downloaded, and will try on my machine later on this evening.  The audio CD does work, though, as I've used it many times from FC2 through to F9 (but not with KDE 4.1, although from what you indicate, this might not be the problem).  Perhaps the latest kernel will fix the I/O problem.

The KsCD 'window' states "NO DISC" when the program is loaded and the CD loaded.
Comment 6 Marc 2008-08-12 04:26:59 EDT
Created attachment 314069 [details]
I/O Log 11 August 2008

As it has been noted that the bug could be with the kernel, I'm only updating the kernel and its dependency (kernel-firmware) to see if KsCD and Kaffeine start to work with this update alone.  I haven't updated any other packages in F10 Alpha so far as a test.  If the kernel maintenance team advise of any other updates to go with the kernel and its dependency to make KsCD and Kaffeine function, please could you advise me.

I updated the kernel and kernel-firmware packages, as noted in the attachment.  The first kernel update did not make KsCD and Kaffeine work, and neither did the second kernel update.  You will note the output in the terminal after each kernel update:

/sbin/ldconfig: /lib/ld-linux.so.2 is not a symbolic link

I also noted that my USB has ceased to function following the kernel updates, and the output from the log can be seen in the attachment.  The CD drawer has also started automatically closing before I can take out the CD.

KsCD and Kaffeine still do not work with audio CDs.  However, the default music player, Rhythmbox, which comes up as the first choice when an audio CD is loaded, does import the tracks, and does play the music, using the same CD that KsCD and Kaffeine won't play.  KsCD still shows “NO DISC” in its window.
Comment 7 Marc 2008-10-23 04:20:40 EDT
Created attachment 321253 [details]
Some improvement in KsCD and Kaffeine

Tested F10 Snapshot 2 DVD (17/10/2008) on a full installation, and KsCD and Kaffeine (see report 458034) have some function now.  Both media players now recognize a CD is in the CD player, and both load the tracks and start playing.  However, with both, the music jumps, and the system volume is low (54%), and even after setting the system volume higher, the volume reverts to 54% on reboot.

Anaconda is fragile, as it threw up a message on first attempted installation, but I was able to install Snapshot 2 via the DVD after the second attempt (this was also noted with the recent keyboard issue, which is now fixed 458028).  I couldn't save the anaconda output to disk, but transcribed the first few lines in case they're any help:

Anaconda 11.4.1.49 exception report.  Traceback (most recent call first):  File”/usr/lib/anaconda/iw/netconfigdialog.py”, line67, in_netdev Changed val= combo.get_model(). Getvalue (active) Type error iter must be a GtkTreelter

The login screen also has a problem in that it doesn't recognize an attempt to login as root (other), so I couldn't test CD playing in root.  I enclose the system log after first installation of snapshot 2 (DVD), and after rebooting to test the CD playing, for information, which notes I/O errors.
Comment 8 Rex Dieter 2008-10-23 07:30:32 EDT
One issue per bug please (this bug is about kernel/audio-cd's)
Comment 9 Bug Zapper 2008-11-25 21:40:46 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Mary Ellen Foster 2009-05-29 06:09:58 EDT
Is this the same as bug 495538?
Comment 11 Kevin Kofler 2009-05-29 07:54:47 EDT
*** Bug 495538 has been marked as a duplicate of this bug. ***
Comment 12 Mary Ellen Foster 2009-05-29 08:20:10 EDT
*** Bug 497716 has been marked as a duplicate of this bug. ***
Comment 13 Kev 'Kyrian' Green 2009-07-08 12:03:55 EDT
I have this problem, although if they do differ, the errors I get in dmesg are more like those from #497716.

I figured it might be related to some kind of profile setting somewhere, so created a new user, and the CD would be recognised (although no CDDB because I tested with a recent magazine cover CD [audio only]).

It worked with a new user, but not with my original.

I'd be very keen to be able to get this to work with my original user where all my data is, so any suggestions which parts of config are likely to be related to this?

It may be down to my using XFCE for the troubled profile, and just default options for the new user??

Anyway, I think it might be a good idea, so I'm including from my X session log [~/.xsession-errors], stuff which *might* be related and I can't explain through prior knowledge of other issues:

** (xfwm4:4136): CRITICAL **: getBoolValue: assertion `G_VALUE_TYPE(rc[i].value) == G_TYPE_BOOLEAN' failed

...

(xfce4-panel:4137): xfce4-panel-WARNING **: Failed to create plugin "websearch"
Could not parse arguments: Unknown option --load-session

...

(xfce4-cpugraph-plugin:4143): Gtk-CRITICAL **: gtk_container_set_border_width: assertion `GTK_IS_CONTAINER (container)' failed
Could not parse arguments: Unknown option --load-session
Could not parse arguments: Unknown option --load-session
Could not parse arguments: Unknown option --load-session
Could not parse arguments: Unknown option --load-session
Could not parse arguments: Unknown option --load-session
Unknown option --sm-client-id
Run 'krb5-auth-dialog --help' to see a full list of available command line options

...

(rhythmbox:4214): Rhythmbox-WARNING **: Unable to grab media player keys: Could not get owner of name 'org.gnome.SettingsDaemon': no such name

...

N: alsa-sink.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
N: alsa-source.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
Warning: unrecognized command line flag -contentLocale
Comment 14 Marc 2009-07-16 04:07:56 EDT
Created attachment 353954 [details]
KsCD log file F11 July 2009

Just tried KsCD after recent updates (up to 9th July 2009) and KsCD now detects the CD and plays it.  However, it plays the disk faster than it should and it is the same with Kaffeine regarding playing too fast.  Enclosed is the system log for the period, and I/O errors can be seen as well as a note about an alsa bug.
Comment 15 Marc 2009-07-27 04:09:58 EDT
Created attachment 355244 [details]
KsCD log file 27 July 2009

I've just added the latest updates to 19th July 2009 and KsCD once again doesn't recognize there is a CD in the drive (Kaffeine does play, but slightly fast).  Enclosed is the system log.
Comment 16 Kev 'Kyrian' Green 2009-07-28 08:29:21 EDT
Further to my Comment #13 I've just tried this again and I cannot see CD's on another new user. It's possible I was using different kernel versions between attempts, or something like that.

This is with Rhythmbox, rather than KSCD.

I get this sort of block of messages a couple of times in a row when I put the CD in to start with:

Buffer I/O error on device sr0, logical block 0
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0

This happens with a new or existing user, and regardless of which of my two CD drives I put the disk into, and with at least two different audio CD's.

Similar bugs seem to hint at kernel or udev issues, but I can't work out which udev/kernel to go back to in order to fix this. If someone could tell me that would be great?
Comment 17 Kev 'Kyrian' Green 2009-07-29 06:12:37 EDT
I figured I'd compile a custom kernel overnight to see if that solved the problem.

I used the config files from kernel-2.6.29.6-213.fc11.src.rpm (config-generic, config-x86_64-generic) and vanilla kernel source 2.6.30.3.

That seems to have modified the problem, in that "SUGGEST_OK" is now missing, but I still cannot access a CD in either CD-ROM drive.

The dmesg output from that revised kernel is blocks like this:

Buffer I/O error on device sr0, logical block 2
Buffer I/O error on device sr0, logical block 3
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0

That implies the kernel has at least some part to play in the problem, but I don't know, I'm just providing the information in case it helps nail this.

Of course, as alluded to above, this is a 64-bit system, running the i686/i386 version of Fedora.

CPU is: AMD Athlon(tm) 64 Processor 3000+

Perhaps there is some important factor there.
Comment 18 James T Perkins 2009-07-29 19:25:30 EDT
I have seen this problem as well, F11  up to date as of present, 2.6.29-213.fc11.x86_64, AMD Athlon(tm) 64 FX-60 Dual Core Processor

scsi1 : pata_sis
ata1: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
...
ata1.01: ATAPI: Optiarc DVD RW AD-7170A, 1.02, max UDMA/66
ata1.01: configured for UDMA/66
isa bounce pool size: 16 pages
scsi 0:0:1:0: CD-ROM            Optiarc  DVD RW AD-7170A  1.02 PQ: 0 ANSI: 5
sr0: scsi3-mmc drive: 40x/40x writer dvd-ram cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 0:0:1:0: Attached scsi CD-ROM sr0
sr 0:0:1:0: Attached scsi generic sg0 type 5
...
sr 0:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 0:0:1:0: [sr0] Sense Key : Illegal Request [current] 
sr 0:0:1:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 972416
Buffer I/O error on device sr0, logical block 243104
Buffer I/O error on device sr0, logical block 243105
sr 0:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 0:0:1:0: [sr0] Sense Key : Illegal Request [current] 
sr 0:0:1:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 972416
Buffer I/O error on device sr0, logical block 243104
Buffer I/O error on device sr0, logical block 243105
sr 0:0:1:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 0:0:1:0: [sr0] Sense Key : Illegal Request [current] 
sr 0:0:1:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
Buffer I/O error on device sr0, logical block 1
Buffer I/O error on device sr0, logical block 2
Buffer I/O error on device sr0, logical block 3
Buffer I/O error on device sr0, logical block 4
...

http://forums.fedoraforum.org/showthread.php?p=1247210 noted that installing backdated udev, libudev, and libvolume_id packages (to v. 141-3) would get past this behavior... it did, but this only delayed broken capability - track lengths were not read correctly in any case.
Comment 19 Kev 'Kyrian' Green 2009-07-30 09:23:16 EDT
Damn. Why did you have to say that after I'd already upgraded to current 'development' versions trying to fix it, and failed.. ;-(

Here are my currently installed versions of the packages you mention above, for reference:

udev-145-2.fc12.i686
libudev-145-2.fc12.i686
libvolume_id-141-4.fc11.i586

I'll check out the bug report you mention and see if I can coax a good combination out of my system.

K.
Comment 20 Kev 'Kyrian' Green 2009-08-02 06:36:28 EDT
So, I was running an ix86 kernel on a 64 bit chip, I realised, and thought my last possible option was to move to the x86_64 kernel & release in hopes of resolving this issue.

That, my good Fedora folks was a painful and lengthy process, which could be streamlined, by, umm, several days!

In any case, it did not resolve the matter, here's what the revised installation gives me in dmesg:

sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0

With:

kernel-2.6.31-0.103.rc4.git2.fc12.x86_64
hal-0.5.13-5.fc12.x86_64
udev-145-2.fc12.x86_64
libvolume_id-141-3.fc11.x86_64

Help, please, I have no more ideas left.
Comment 21 Marc 2009-08-18 04:24:28 EDT
Just installed recent updates on F11, including kernel-PAE-2.6.29.6-217.2.7.fc11.i686.rpm, and KsCD now plays CDs properly (so does Kaffeine).
Comment 22 Tomas Toth 2009-08-29 16:31:55 EDT
Created attachment 359167 [details]
Fedora 12 Alpha /var/log/messages
Comment 23 Tomas Toth 2009-08-29 16:33:22 EDT
Created attachment 359168 [details]
Fedora 12 Alpha dmesg
Comment 24 Tomas Toth 2009-08-29 16:41:35 EDT
The issue still persists in Fedora 12 Alpha, for details please refer to Comment #22 and Comment #23. The errors are at the tail of the files, time stamp: Aug 29 20:03:28.

Could this issue get higher priority, it starts to be annoying, not to be able to play any Audio CDs for about a year now.

Thanks
Comment 25 Bruce Brackbill 2009-09-02 02:43:28 EDT
I still have this bug on F11:

Sep  1 23:39:28 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Sep  1 23:39:28 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Sep  1 23:39:28 localhost kernel: Info fld=0x0
Sep  1 23:39:28 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Sep  1 23:39:28 localhost kernel: end_request: I/O error, dev sr0, sector 0
Sep  1 23:39:28 localhost kernel: __ratelimit: 8 callbacks suppressed
Sep  1 23:39:28 localhost kernel: Buffer I/O error on device sr0, logical block 0
Sep  1 23:39:28 localhost kernel: Buffer I/O error on device sr0, logical block 1
Sep  1 23:39:28 localhost kernel: Buffer I/O error on device sr0, logical block 2
Sep  1 23:39:28 localhost kernel: Buffer I/O error on device sr0, logical block 3
<snip>

# uname -a
Linux localhost.localdomain 2.6.30.5-43.fc11.i686.PAE #1 SMP Thu Aug 27 21:34:36 EDT 2009 i686 i686 i386 GNU/Linux
Comment 26 Daniel Qarras 2009-09-17 10:54:18 EDT
Me too! Also with:

Linux localhost.localdomain 2.6.30.5-43.fc11.i586 #1 SMP Thu Aug 27 21:18:54 EDT 2009 i686 i686 i386 GNU/Linux

> Could this issue get higher priority, it starts to be annoying, not to be
> able to play any Audio CDs for about a year now.

Indeed.
Comment 27 Karl S. 2009-09-21 22:09:43 EDT
More than annoying, this bug is embarrassing.  It gives linux a black eye.  You
can't even rip a CD.
Comment 28 Patrick C. F. Ernzer 2009-09-24 05:03:59 EDT
FWIW, I was pointed at this bug by a colleague.

Tried 3 F11 boxes (2 x86_64 and 1 i386), all play CDDA just fine. While I do get entries in dmesg like comment #25 at the start of the test this is not preventing audio playback.

Question to bug owner; what info would you like from the 3 boxes I tested on? 

The drives used for testing on the boxes are:
  MATSHITA DVD/CDRW UJDA775 CB03
  TSSTcorp CDDVDW SH-S203N  SB02
  TSSTcorp DVD-ROM SH-D163B SB01
Comment 29 Marc 2009-09-24 05:27:18 EDT
As noted at the beginning of this thread, the KsCD problem started with F10 Alpha, but as noted in comment 21, KsCD functioned fine with this kernel on an i686.  In all cases, my drive was an LG DVD writer (don't know the model number).
Comment 30 Marc 2009-09-25 04:16:39 EDT
Just to add to my comment 29 above, my LG DVD writer model number is HL-DT-STDVD-RAM GSA-H22N.  KsCD (and Kaffeine) still function with the latest updated kernel-PAE-2.6.30.5-43.fc11.i686.rpm and with all the latest KDE updates, at least on my i686 system, so perhaps some of the issues still present with some of the comments above could be hardware related?
Comment 31 Daniel Qarras 2009-09-25 10:13:42 EDT
> so perhaps some of the issues still present with some of the comments above
> could be hardware related?

I don't believe this for two reasons:

- my system is a dual-boot laptop with WinXP and F11. Under WinXP my CDs work just perfectly, nothing hints about hardware/disc issues.

- earlier Fedoras worked ok in this regard - I think F9 at least was ok. (I use CD rarely so can't remember for sure, sorry.)

Once F12Beta is out I'm going to wipe my F11 and install F12B. I think at that time I'll install F9/F10 and try different kernel versions to see if there is some update which broke this.

Thanks.
Comment 32 Karl S. 2009-09-26 00:32:48 EDT
I have two different drives with the same problem.  Both have been updated with
their latest firmware.  So I don't think it's the hardware.

kernel-2.6.27.30-170.2.82.fc10.i686

From dmesg:
ata_piix 0000:00:1f.1: version 2.12
ata_piix 0000:00:1f.1: PCI INT A -> GSI 22 (level, low) -> IRQ 22
ata_piix 0000:00:1f.1: setting latency timer to 64
scsi0 : ata_piix
scsi1 : ata_piix
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xffa8 irq 15
ata1.00: ATAPI: DVD-RW IDE1108, VER B430, max UDMA/66
ata1.01: ATAPI: LITE-ON COMBO SOHC-5236V, R$0G, max UDMA/44
ata1.00: configured for UDMA/66
ata1.01: configured for UDMA/44
scsi 0:0:0:0: CD-ROM            DVDRW    IDE1108          B430 PQ: 0 ANSI: 5
sr0: scsi3-mmc drive: 1x/40x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 0:0:0:0: Attached scsi CD-ROM sr0
sr 0:0:0:0: Attached scsi generic sg0 type 5
scsi 0:0:1:0: CD-ROM            LITE-ON  COMBO SOHC-5236V R$0G PQ: 0 ANSI: 5
sr1: scsi3-mmc drive: 0x/52x writer cd/rw xa/form2 cdda tray
sr 0:0:1:0: Attached scsi CD-ROM sr1
sr 0:0:1:0: Attached scsi generic sg1 type 5

Error messages are the same as have been posted above.
Comment 33 Joachim Backes 2009-09-29 11:05:28 EDT
Having similar problems, both with kscd and rhythmbox.
From dmesg:

Sep 29 17:00:00 eule kernel: Buffer I/O error on device sr2, logical block 1
Sep 29 17:00:00 eule kernel: sr 4:0:0:0: [sr2] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Sep 29 17:00:00 eule kernel: sr 4:0:0:0: [sr2] Sense Key : Illegal Request [current] 
Sep 29 17:00:00 eule kernel: Info fld=0x0, ILI
Sep 29 17:00:00 eule kernel: sr 4:0:0:0: [sr2] Add. Sense: Illegal mode for this track
Sep 29 17:00:00 eule kernel: end_request: I/O error, dev sr2, sector 0
Sep 29 17:00:00 eule kernel: Buffer I/O error on device sr2, logical block 0
Sep 29 17:00:00 eule kernel: Buffer I/O error on device sr2, logical block 1

I filed a bug for kernel-2.6.30.5-43.fc11.i586:

https://bugzilla.redhat.com/show_bug.cgi?id=526229
Comment 34 Daniel Qarras 2009-10-21 09:30:16 EDT
I now did a lots of testing and what I found was:

Fedora 9 worked all ok for me - also with 2.6.29 and 2.6.31 kernel from kernel.org.

Fedora 10 worked all ok for me - also with 2.6.29 and 2.6.31 kernel from kernel.org.

When upgrading from F10 to F11, my audio CDs kept on working over kernel/udev/GNOME/Xorg updates (I updated them in different sets and rebooted several times). However, after installing these updates on a half F10, half F11 system things fall apart:

gvfs-smb-1.2.3-12.fc11
gvfs-gphoto2-1.2.3-12.fc11
gvfs-fuse-1.2.3-12.fc11
gvfs-obexftp-1.2.3-12.fc11
gvfs-archive-1.2.3-12.fc11
gvfs-1.2.3-12.fc11
gnome-disk-utility-libs-0.3-1.fc11
DeviceKit-disks-004-4.fc11
libatasmart-0.12-3.fc11
libcdio-0.81-2.fc11

So it seems that at least on my system it's not the kernel's fault but either gvfs or DeviceKit-disks. Especially considering that I saw those same I/O errors in dmesg even when the system was working (i.e., they did not prevent listening to an audio CD before gvfs/DeviceKit-disks update)

I shall install Fedora 12 Beta next and will report how things are working with it.
Comment 35 Daniel Qarras 2009-10-22 06:22:47 EDT
Great news, with Fedora 12 Beta this is working for me finally.

FWIW, dmesg still shows the I/O errors (for all my CDDAs) but both Totem and Rhythmbox are able to play CDs.
Comment 36 Feng Yu 2009-10-24 18:37:52 EDT
what version of the so mentioned packages do you have on F12 Beta?
Comment 37 Feng Yu 2009-10-24 18:43:08 EDT
Please refer to bug 513495. Devkit-disks-004-5 is said to have the problem partially fixed.
Comment 38 Nicola Soranzo 2009-10-26 05:31:03 EDT

*** This bug has been marked as a duplicate of bug 513495 ***

Note You need to log in before you can comment on or make changes to this bug.