Bug 495575 - system freeze at first reboot (RAID + LVM setup)
system freeze at first reboot (RAID + LVM setup)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 495581
  Show dependency treegraph
 
Reported: 2009-04-13 16:25 EDT by Matthieu Araman
Modified: 2009-04-27 10:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 10:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthieu Araman 2009-04-13 16:25:30 EDT
Description of problem:
After workaround for bug 495552, system boot until X start and reach first boot screen.
system is instantly frozen (no keyboard, no mouse, have to force reboot)

Version-Release number of selected component (if applicable):
install from boot.iso 20090404 (see parent bug for config)

How reproducible:
Always

Steps to Reproduce:
1. boot 
2.
3.
  
Actual results:
freeze

Expected results:
not freeze

Additional info:
after this occurs, I can no longer mount the system via fedora 11 beta rescue mode (anaconda exception). will open a bug for this.
I can see some messages flowing before the problem.
I see many errors 
it's very fast and I don't know how to pause it.
Not sure but I think there's a problem with libc not found...
Comment 1 Matthieu Araman 2009-04-13 17:58:23 EDT
Log files from system install 20090404 at http://plouic.com/fedora-matzilla/rawhide20090404/
anaconda log files
content of /var/log
X first boot.log before freeze
Comment 2 Matthieu Araman 2009-04-13 18:29:21 EDT
Some progress :
after solving the partition problems, I could (from the chroot /rescue mode) :
- change inittab default level to 3 from 5
- disable firstboot (chkconfig)

-> The system seems stuck but in console mode and I still have keyboard to go up.
There are some minor error message but I think raid and lvm + mounting starts ok
After this, I see the quota activated ok
then swap activated ok
then looks very wrong :
/sbin/consoletype: error while loading shared libraries: libc.so.6: cannot open shared object file: Permission denied
same error repeated a lot of time as the boot process continue
other similar error :
ip6tables : .... : ip6tables-restore: error while loading shared libraries: libiptc.so.0: cannot open shared object file: Permission denied
rsyslogd: error while loading shared libraries: libz.so.1: cannot open shared object file: Permission denied
irqbalance : .... libglib-2.0.so.0
rpcbind ...libwrap.so.0
lots of similar errors
lots of KO

then many :
init: tty4 main process (2257) terminated with status 127
init: tty4 main process ended, respawning
...
........respawning too fast : disabled

then audit and avc denied

and nothing

My guess : there's some problem with ldconfig at install time ???

In this setup, I can press ctrl-alt-suppr (with X Window started, I was stuck)
Comment 3 Matthieu Araman 2009-04-13 18:54:49 EDT
Ok, I found what's wrong.
ldconfig cache looks good.
file permissions are good.

By adding selinux=0 in grub.conf, the errors disappears and I can go to the login prompt.

So either there was a bug in a rpm which didn't updated the selinux bit at install time or the install process forgot something or this occurs only when with lvm + raid ????

Is it known ? corrected ?
Can I provide more info ?
which one ?
Comment 4 Matthieu Araman 2009-04-13 19:07:37 EDT
reenabled init level 5 + firstboot + selinux
at boot time, there's a message about changing of selinux policy to targeted and the system automatically runs for a few minutes relabelling.
after this, I get the firstboot screen.
Comment 5 giulio 2009-04-15 16:19:53 EDT
Can confirm this bug.
Further, when / and /usr are on different LVMs, SElinux denies access to /usr where all the libraries mentioned above are located.
With kernel options enforce=0 on boot or modify to SElinux config this get going.

Can reproduce by installing with / and /usr on different LVMs. Result non functional boot process.

Did not try, however, to put / and /usr on actual different disk partitions.
Comment 6 Matthieu Araman 2009-04-26 08:04:17 EDT
As bug 495552 has been corrected, fist boot is correct and I no longer have a freeze problem.
My guess is that selinux permissions are now set correctly.
I think the underlying problem is that if the first boot fail for some reason, some selinux initialisation can't occur and even after correcting the root cause, the initial selinux initialisation never occurs and you have to force it one way or another...
IMHO, this bug could be closed.

Note You need to log in before you can comment on or make changes to this bug.