Bug 495588 - VM Universe documentation says VM_MEMORY is megabytes not bytes.
VM Universe documentation says VM_MEMORY is megabytes not bytes.
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.1
All Linux
low Severity medium
: 1.2
: ---
Assigned To: Matthew Farrellee
Luigi Toscano
:
: 498346 (view as bug list)
Depends On:
Blocks: 527551
  Show dependency treegraph
 
Reported: 2009-04-13 17:30 EDT by Charlie Wyse
Modified: 2010-10-23 04:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Grid bug fix C: The VM_MEMORY setting in condor_config is set to 128 bytes by default, not 128000 bytes (128MB) C: Virtual machines are created with the wrong amount of memory F: The setting is now converted to the correct measurements R: Memory is now set as expected The default setting for VM_MEMORY in condor_config was creating virtual machines with the wrong amount of memory. The setting now converts the amount correctly, and virtual machine memory is now set correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 04:16:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Wyse 2009-04-13 17:30:42 EDT
Description of problem:
VM_MEMORY in condor_config is set to "128" as default.  This value is in bytes not megabytes.  Jobs with anything under 128000 will results in 128M because of libvirtd.  Also when creating jobs you must specify the amount of memory in bytes.

Version-Release number of selected component (if applicable):
condor-7.2.2-0.9.el5

How reproducible:
Every time.

Steps to Reproduce:
1. Set VM_MEMORY to 8192 in condor_config
2. Create a VM job with VM_MEMORY at 4096
3. Start VM job and notice the virtual machine was started with 128M
4. Repeat steps 1 & 2 by adding 000 to the end of the numbers.
5. Watch them start up with the desired memory.
  
Actual results:
Machines are created with the wrong amount of memory because the documentation says to create memory with size in Megabytes.

Expected results:
Jobs and memory utilization is recorded in bytes not megabytes.

Additional info:
Comment 1 Charlie Wyse 2009-04-13 19:30:50 EDT
Even StartLog reads everything as MB instead of B.  That information log should be changed as well.
4/13 16:29:25 The maximum available memory for vm universe is set to 64000000 MB
Comment 2 Matthew Farrellee 2009-04-13 19:54:26 EDT
This needs to be verified in MRG and UW documentation. It is possible this is the result of differences between VMware and libvirt support - if so it must be resolved upstream, likely by converting for libvirt.

Also, it seems for libvirt the memory parameter is in kilobytes, not bytes.
Comment 3 Lana Brindley 2009-04-13 20:02:50 EDT
When you are ready for documentation changes, please change the component to Grid_User_Guide and assign the bug to me.

Thanks,
LKB
Comment 4 Matthew Farrellee 2009-05-01 11:43:56 EDT
This has been resolved upstream. Should be available in 7.3.1-0.4.

The issue was VMware and xm use MiB units and libvirt uses KiB, but conversion to KiB was not done.
Comment 5 Matthew Farrellee 2009-05-01 11:45:26 EDT
*** Bug 498346 has been marked as a duplicate of this bug. ***
Comment 8 Irina Boverman 2009-10-28 13:18:45 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Corrected problem with VM_MEMORY parameter conversion to KiB when invoking libvirt (495588)
Comment 9 Lana Brindley 2009-11-03 21:33:34 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,3 @@
+Grid bug fix
+
 Corrected problem with VM_MEMORY parameter conversion to KiB when invoking libvirt (495588)
Comment 10 Lana Brindley 2009-11-03 22:01:00 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,3 +1,8 @@
 Grid bug fix
 
-Corrected problem with VM_MEMORY parameter conversion to KiB when invoking libvirt (495588)+C: The VM_MEMORY setting in condor_config is set to 128 bytes by default, not 128000 bytes (128MB)
+C: Virtual machines are created with the wrong amount of memory
+F: The setting is now converted to the correct measurements
+R: Memory is now set as expected
+
+The default setting for VM_MEMORY in condor_config was creating virtual machines with the wrong amount of memory. The setting now converts the amount correctly, and virtual machine memory is now set correctly.
Comment 11 Luigi Toscano 2009-11-06 11:40:15 EST
The amount of memory is converted to the right unit. 
Tested on RHEL 5.4 on i386 Xen, x86_64 Xen and x86_64 KVM.
condor-7.4.1-0.4
condor-vm-gahp-7.4.1-0.4

Changing the status to VERIFIED.
Comment 12 errata-xmlrpc 2009-12-03 04:16:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1633.html

Note You need to log in before you can comment on or make changes to this bug.