Bug 498346 - vm-gahp mishandling job's vm_memory
vm-gahp mishandling job's vm_memory
Status: CLOSED DUPLICATE of bug 495588
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
1.1.1
All Linux
high Severity high
: 1.2
: ---
Assigned To: Matthew Farrellee
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 20:36 EDT by Matthew Farrellee
Modified: 2009-05-01 11:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-01 11:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2009-04-29 20:36:01 EDT
Description of problem:

condor_submit's manual page says vm_memory is in MiB, the VM_MEMORY configuration for the vm gahp says it is in MiB, and libvirt says that the <memory> element of the VM's <domain> is in KiB.

However, the vm-gahp was passing vm_memory through to libvirt without doing the MiB->KiB conversion.

Version-Release number of selected component (if applicable):

condor before 7.3.1-0.3

How reproducible:

100%

Steps to Reproduce:
1. Treat the vm_memory as if it is MiB and notice the small memory size for a running domain with virsh
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Farrellee 2009-04-29 20:46:36 EDT
A workaround for versions of Condor with this bug is to treat both the vm_memory submit command and VM_MEMORY configuration as if they were in KiB. After the bug is fixed they need to be treated as MiB.
Comment 2 Matthew Farrellee 2009-05-01 11:45:25 EDT

*** This bug has been marked as a duplicate of bug 495588 ***

Note You need to log in before you can comment on or make changes to this bug.