Bug 495691 - anaconda refuses to create primary partition if 3 others already exist
anaconda refuses to create primary partition if 3 others already exist
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
:
: 505269 516211 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 08:46 EDT by James Cassell
Modified: 2009-10-02 03:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 10:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Cassell 2009-04-14 08:46:05 EDT
Description of problem:
There are three primary partitions, and free space before the final partition.  When trying to create a primary partition in this space (via the force primary checkbox,) anaconda complains that there isn't enough space.  Without the checkbox, it tries to add an extended partition in the free space.

Version-Release number of selected component (if applicable):
11.5.0.41

How reproducible:
always

Steps to Reproduce:
1. have a disk with 3 primary partitions with free space between the second and third
2. try to create a primary partition on the free space within anaconda
3. witness the error
  
Actual results:
an error is produced

Expected results:
anaconda should create the primary partition

Additional info:
I couldn't find the answer to this: is the extended partition allowed to be a partition other than the final partition?  If not, that's another bug or part of this bug.
Comment 1 Joel Andres Granados 2009-04-17 09:56:15 EDT
In my tests, this did not produce an error, but it did not allow me to create a primary partition with the "force primary" switch.  It just created a extended partition and inside that one, created a logical one with the parameters I had intended for the primary.
Comment 2 Bug Zapper 2009-06-09 09:48:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Andy Lindeberg 2009-08-04 15:34:54 EDT
*** Bug 505269 has been marked as a duplicate of this bug. ***
Comment 4 Andy Lindeberg 2009-08-07 10:24:24 EDT
*** Bug 516211 has been marked as a duplicate of this bug. ***
Comment 5 Joel Andres Granados 2009-08-07 10:40:49 EDT
The results of my tests:

1. I could create 4 primary (forced) partitions.  And  the last partition did not span the size of the drive.

2. The same as 1, but the last partition spans the whole size of the drive. (like it should be)

Pls retest with anaconda-12.10
Comment 6 Karel Volný 2009-08-10 06:46:07 EDT
ok, my problem (bug #516211) does not appear with boot.iso from the recent rawhide-20090809, seems fixed
Comment 7 stef 2009-08-26 12:07:46 EDT
The problem is not closed for me, and in fact I'm in trouble !

Due to this bug it is impossible to install on a category of our computers :

we have the following partitionning scheme
1- Ghost Boot partition (used for Ghost deploying)
2- Windows system (C:)
3- Windows Users files and Profiles (D:)

so, the 4th partition is to be free for Linux, HOWEVER, with this bug it is impossible to create a working Linux installation.

The / partition is to be the only Linux type partition and is to be created in number 4 (the swap is to be a file in the filesystem), but anaconda refused claiming there's no free space.

I tryed a workaround by creating the partition as a set of %pre commands with parted.
Works for the partition creation, but after that I get a displeasant "Bootable partitions cannot be on an ext4 filesystem"... funny, I didn't create any.
"This can happen if there is not enough space on your hard drive for the installation" ... so 100+ GB is not enough now ?

is there a way to go around this, like a "stage2.img" correction file ?
Comment 8 stef 2009-08-27 04:02:48 EDT
I found a 'solution' (sort of) to make the install work :

1- create manually the 4th primary partition formated in ext3 booting the FC11 CD-rom
2- modify the kickstart files like such :

#clearpart --linux
#part / --asprimary --fstype="ext3" --grow --size=1
part / --usepart=/dev/sda4 --noformat

the --noformat option is necessary since it will try to format in ext4 without it, and Grub does not boot on such format in FC11

3- boot with the kickstart file as parameter and the install should run fine


This kinda defeat the purpose of AUTOMATED installation tough ...
Comment 9 Martin Sivák 2009-08-27 04:51:35 EDT
Well, yes GRUB didn't support ext4 formated /boot. But it shoould work now (in rawhide).

Is it really still impossible to create fourth primary partition using current rawhide? Because it worked in our testing environment. If the grub is not fixed, you should be able to select ext3 as the desired filesystem for the partition.

What version of anaconda did you use to your test yesterday?
Comment 10 stef 2009-08-27 05:00:48 EDT
I'm using the stock CD/DVD of FC11

can the Rawhide boot image install the FC11 distro ?

If so can you give me the URL for the files up-to-date please.
Comment 11 Martin Sivák 2009-08-27 06:11:45 EDT
No bugfix will make it into F11 boot images now, all new patches are flowing into rawhide.

And no, it is not officially possible to install F11 with rawhide installer.
Comment 12 James Laska 2009-10-01 14:45:14 EDT
(In reply to comment #10)
> I'm using the stock CD/DVD of FC11
> 
> can the Rawhide boot image install the FC11 distro ?
> 
> If so can you give me the URL for the files up-to-date please.  

Stef:  Have you been able to confirm whether the reported problem is resolved with F-12 (or Rawhide)?  You can find information for downloading and testing Rawhide at https://fedoraproject.org/wiki/Releases/Rawhide#Installing_Rawhide
Comment 13 stef 2009-10-02 03:19:54 EDT
>Have you been able to confirm whether the reported problem is resolved
with F-12 (or Rawhide)?

No, I didn't test it, and I won't have the time to do so ATM.

I'll have a look at the distro for our next deployment project around may/june next year.
It should be around time for FC13, I hope such problem will be fixed by then.

Note You need to log in before you can comment on or make changes to this bug.