Bug 505269 - can't create four primary partitions with kickstart
can't create four primary partitions with kickstart
Status: CLOSED DUPLICATE of bug 495691
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
: 500250 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 05:39 EDT by stef
Modified: 2009-08-04 15:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-04 15:34:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stef 2009-06-11 05:39:17 EDT
Description of problem:

I use kickstart to make some mass-install of Fedora workstations, this system is in place since FC2, is revised at each distro we want to use and run without problem since.

We use the following partition scheme :

1- DOS partition primary hidden (ghost agent)
2- NTFS partition primary (Windows XP)
3- Linux partition primary (for / )
4- Swap partition primary

in kickstart shows as :

# disk partitioning information
part swap --asprimary --fstype="swap" --size=2048
part / --asprimary --fstype="ext3" --grow --size=1


But with FC11 something appeared, anaconda refuses to create my Linux partitions as primary giving a "Could not allocate requested partitions"

changing to 

# disk partitioning information
part swap --fstype="swap" --size=2048
part / --asprimary --fstype="ext3" --grow --size=1

Solves the issue but gives a uselessly complicated partition scheme :

1- DOS partition primary hidden (ghost agent)
2- NTFS partition primary (Windows XP)
3- Linux partition primary (for / )
4- Extended partition
5- Swap partition logical

Version-Release number of selected component (if applicable):

Fedora Core 11

How reproducible:

Always

Steps to Reproduce:
1.create 2 primary partitions on disk plus space left
2.create a kickstart asking to create 2 more primary partitions
3.launch the install on the kickstart
  
Actual results:

gives a "Could not allocate requested partitions" messages and abord install

Expected results:

create the 2 supplementary primary partitions as expected giving 4 primary partitions on disk

Additional info:
Comment 1 Chris Lumens 2009-07-17 16:51:05 EDT
*** Bug 500250 has been marked as a duplicate of this bug. ***
Comment 2 Andy Lindeberg 2009-08-04 15:34:54 EDT

*** This bug has been marked as a duplicate of bug 495691 ***

Note You need to log in before you can comment on or make changes to this bug.