This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 495763 - anaconda fails in setRootPassword
anaconda fails in setRootPassword
Status: CLOSED DUPLICATE of bug 495708
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:de0927871c287b043...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 13:26 EDT by Geoff Levand
Modified: 2009-04-15 04:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 13:29:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (128.31 KB, text/plain)
2009-04-14 13:26 EDT, Geoff Levand
no flags Details
Attached traceback automatically from anaconda. (189.05 KB, text/plain)
2009-04-15 04:08 EDT, A.J. Werkman
no flags Details

  None (edit)
Description Geoff Levand 2009-04-14 13:26:31 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.44 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/users.py", line 159, in setRootPassword
    self.admin.setpassUser(rootUser, cryptPassword(password, algo=algo), True)
  File "/usr/lib/anaconda/instdata.py", line 171, in write
    algo=self.getPassAlgo())
  File "/usr/lib/anaconda/backend.py", line 302, in writeConfiguration
    anaconda.id.write()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 701, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 966, in <module>
    anaconda.intf.run(anaconda)
TypeError: argument 2 must be string, not None
Comment 1 Geoff Levand 2009-04-14 13:26:35 EDT
Created attachment 339529 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-04-14 13:29:40 EDT

*** This bug has been marked as a duplicate of bug 495708 ***
Comment 3 A.J. Werkman 2009-04-15 04:08:35 EDT
Created attachment 339640 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.