Bug 495708 - TypeError: argument 2 must be string, not None
TypeError: argument 2 must be string, not None
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kai Engert (:kaie)
Fedora Extras Quality Assurance
:
: 495763 (view as bug list)
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-04-14 09:50 EDT by James Laska
Modified: 2013-09-02 02:34 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 16:33:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (176.44 KB, text/plain)
2009-04-14 09:50 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-04-14 09:50:42 EDT
Created attachment 339493 [details]
anacdump.txt

Description of problem:

Traceback during Anaconda storage test day.  The traceback occurs at the end of package install for the autopart tests (see https://fedoraproject.org/wiki/Test_Day:AnacondaStorageRewrite_2009-04-14#Test)

Version-Release number of selected component (if applicable):
anaconda-11.5.0.44

How reproducible:
Everytime, manual install on a KVM x86_64 guest and real hardware

Steps to Reproduce:
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_autopart_install
  
Actual results:

anaconda 11.5.0.44 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/users.py", line 163, in setRootPassword
    self.admin.setpassUser(rootUser, cryptPassword(password, algo=algo), True)
  File "/usr/lib/anaconda/instdata.py", line 171, in write
    algo=self.getPassAlgo())
  File "/usr/lib/anaconda/backend.py", line 302, in writeConfiguration
    anaconda.id.write()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1344, in handleRenderCallback
    self.currentWindow.renderCallback()
TypeError: argument 2 must be string, not None


Expected results:


Additional info:
Comment 1 Chris Lumens 2009-04-14 13:29:40 EDT
*** Bug 495763 has been marked as a duplicate of this bug. ***
Comment 2 Peter Jones 2009-04-14 14:53:26 EDT
This is because libfreebl3.so is doing its FIPS self-check, and failing because we don't have a libfreebl3.chk file in the installer.

This is two problems:

1) it shouldn't be checking for it in a non-FIPS environment
2) because of the way the .chk file is generated, we don't have them in the install image.
Comment 3 Peter Jones 2009-04-15 14:46:22 EDT
This should be fixed with nss-3.12.3-3 .
Comment 4 Joe Orton 2009-04-15 15:03:23 EDT
Is there any way round this bug until we get a new spin with the fixed nss?
Comment 5 Peter Jones 2009-04-15 15:12:12 EDT
It's fixed in today's tree...
Comment 6 Kai Engert (:kaie) 2009-04-15 16:43:50 EDT
James, can you confirm the problem is gone?
Comment 7 James Laska 2009-04-16 10:37:20 EDT
I cannot retest due to a NetworkManager bug.  I will retest when a fix for bug#495884 has been integrated.
Comment 8 Geoff Levand 2009-04-17 16:12:05 EDT
I tested today's build (17-Apr-2009 12:02) on Mac G5, and this problem seems to be fixed.

 sha1sum ppc/os/ppc/ppc64/{ramdisk.image.gz,vmlinuz}
 b901b623ce3e5ddaca8cb62b8e0fc31ea9874931  ppc/os/ppc/ppc64/ramdisk.image.gz
 9de8ff3a4428d87b07c589eb991696218ba76a33  ppc/os/ppc/ppc64/vmlinuz

-Geoff
Comment 9 Chris Lumens 2009-04-17 16:33:09 EDT
Great, thanks for confirming.

Note You need to log in before you can comment on or make changes to this bug.