Bug 495855 - Text mode partitioning failed
Text mode partitioning failed
Status: CLOSED DUPLICATE of bug 495713
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:dde4bc5a237d71ed1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 02:43 EDT by A.J. Werkman
Modified: 2009-04-15 09:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 09:56:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (51.59 KB, text/plain)
2009-04-15 02:43 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2009-04-15 02:43:09 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.44 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 667, in _addDevice
    if newdev.path in [d.path for d in self._devices]:
  File "/usr/lib/anaconda/storage/devicetree.py", line 1091, in addUdevDiskDevice
    self._addDevice(device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1159, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1588, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 288, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 101, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 701, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 966, in <module>
    anaconda.intf.run(anaconda)
ValueError: object comparing to must be a _ped.DiskType
Comment 1 A.J. Werkman 2009-04-15 02:43:15 EDT
Created attachment 339632 [details]
Attached traceback automatically from anaconda.
Comment 2 A.J. Werkman 2009-04-15 02:47:22 EDT
On anaconda 11.5.0.44 I tried a text mode installation on two blanked out disks with no partitioning information.
I blanked them with dd if=/dev/zero bs=1024k count=10 of=/dev/sd[a,b]
Comment 3 Chris Lumens 2009-04-15 09:56:16 EDT

*** This bug has been marked as a duplicate of bug 495713 ***

Note You need to log in before you can comment on or make changes to this bug.