Bug 495713 - ValueError: object comparing to must be a _ped.DiskType
ValueError: object comparing to must be a _ped.DiskType
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pyparted (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
anaconda_trace_hash:f50b495fc575df28f...
:
: 495822 495855 (view as bug list)
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-04-14 10:02 EDT by James Laska
Modified: 2013-09-02 02:34 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 17:25:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (49.61 KB, text/plain)
2009-04-14 10:02 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (38.54 KB, text/plain)
2009-04-14 12:22 EDT, Scott Dodson
no flags Details
Attached traceback automatically from anaconda. (40.71 KB, text/plain)
2009-04-15 03:50 EDT, Michal Nowak
no flags Details
Attached traceback automatically from anaconda. (41.08 KB, text/plain)
2009-04-15 07:14 EDT, Jens Petersen
no flags Details

  None (edit)
Description James Laska 2009-04-14 10:02:40 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.44 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 667, in _addDevice
    if newdev.path in [d.path for d in self._devices]:
  File "/usr/lib/anaconda/storage/devicetree.py", line 1091, in addUdevDiskDevice
    self._addDevice(device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1159, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1588, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 288, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 101, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
ValueError: object comparing to must be a _ped.DiskType
Comment 1 James Laska 2009-04-14 10:02:44 EDT
Created attachment 339494 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-04-14 10:04:28 EDT
Steps to reproduce:

1. Create a KVM/x86_64 guest
2. Zero out the the virtio disk (dd if=/dev/zero of=/dev/Volume/vguest1-disk0 bs=514 count=20)
3. Initiate install (anaconda-11.5.0.44)
4. Select lang+keyboard
5. When prompted, select to re-initialize drive /dev/vdb

Crash
Comment 3 Scott Dodson 2009-04-14 12:22:13 EDT
Created attachment 339520 [details]
Attached traceback automatically from anaconda.
Comment 4 Chris Lumens 2009-04-14 13:18:20 EDT
This should be fixed in the next build of pyparted.  For now, you can test with updates=http://clumens.fedorapeople.org/updates.img.
Comment 5 James Laska 2009-04-14 13:28:32 EDT
Confirmed the fix using the updates.img in comment#4.  Thank you!
Comment 6 Scott Dodson 2009-04-14 14:05:22 EDT
Confirmed here too. Thanks.
Comment 7 Michal Nowak 2009-04-15 03:50:34 EDT
Created attachment 339638 [details]
Attached traceback automatically from anaconda.
Comment 8 Jens Petersen 2009-04-15 07:14:00 EDT
Created attachment 339665 [details]
Attached traceback automatically from anaconda.
Comment 9 Chris Lumens 2009-04-15 09:56:16 EDT
*** Bug 495855 has been marked as a duplicate of this bug. ***
Comment 10 Chris Lumens 2009-04-15 09:56:29 EDT
*** Bug 495822 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2009-05-06 17:25:43 EDT
Thanks for confirming.

Note You need to log in before you can comment on or make changes to this bug.