Bug 495957 - RFE: make firefox do regular VACUUM of sqlite databases
RFE: make firefox do regular VACUUM of sqlite databases
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: 500744 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2009-04-15 13:47 EDT by Matěj Šusta
Modified: 2009-07-14 09:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-17 19:20:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 352976 None None None Never
Mozilla Foundation 383031 None None None Never
Mozilla Foundation 394379 None None None Never
Mozilla Foundation 395020 None None None Never
Mozilla Foundation 403702 None None None Never
Mozilla Foundation 484646 None None None Never

  None (edit)
Description Matěj Šusta 2009-04-15 13:47:49 EDT
Description of problem:
Firefox 3 is storing lots of profile data in sqlite databases - that's fine.
But after some time, sqlite database need VACUUM command, to optimize the database, without it, Firefox performance will slowly decrease.

Steps to Reproduce:
1. install firefox
2. use firefox long-enough / intensively enough
3. see how long it takes to start it, how's the performance of address bar
Actual results:
Firefox on my Thinkpad T43 was starting about 30 sec., address bar was almost unusable.

Expected results:
After VACUUM of all databases, Firefox starts under 5 sec. and address bar is updating almost realtime as i type.
=> only small amount of people know about this issue and have set their cron/whatever to do this cleanup.
It'll be nice to find way, how to do this automatically.
Comment 1 Matěj Cepl 2009-04-17 19:20:39 EDT
There is huge number of upstream bugs on this theme (I choose https://bugzilla.mozilla.org/show_bug.cgi?id=395020 to be the best one for this bug to be closed against) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 2 Martin Jürgens 2009-05-13 17:57:06 EDT
*** Bug 500744 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.