Bug 500744 - firefox freezes for ~ 20 seconds when clicking on history
firefox freezes for ~ 20 seconds when clicking on history
Status: CLOSED DUPLICATE of bug 495957
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 17:30 EDT by Martin Jürgens
Modified: 2009-07-14 09:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 17:57:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2009-05-13 17:30:53 EDT
Description of problem:
When I reboot my PC, start firefox and click on "History", it takes around 20 seconds for the menu to open. In that time, I can't use Firefox.

Version-Release number of selected component (if applicable):
firefox-3.5-0.20.beta4.fc11.x86_64

How reproducible:
Always

Additional info:
My profile dir has a size of ~ 100 MB

Smolt profile: http://www.smolts.org/client/show/pub_1e50eadf-5973-4f96-90fe-7bc5b1dc467c
Comment 1 Christopher Aillon 2009-05-13 17:42:37 EDT
Known issue.

Ensure that firefox is not running, then from your shell:

  cd $HOME/.mozilla/firefox/*.slt
  cp places.sqlite places.sqlite.backup
  sqlite3 places.sqlite

and from the sqlite prompt:

  sqlite> VACUUM;
  sqlite> .exit

Then restart firefox.

See also
https://developer.mozilla.org/En/Storage:Performance#Vacuuming_and_zero-fill
https://bugzilla.redhat.com/show_bug.cgi?id=495957
https://bugzilla.mozilla.org/show_bug.cgi?id=352976
https://bugzilla.mozilla.org/show_bug.cgi?id=394379
https://bugzilla.mozilla.org/show_bug.cgi?id=395020
Comment 2 Martin Jürgens 2009-05-13 17:57:06 EDT
okay.. thanks

*** This bug has been marked as a duplicate of bug 495957 ***

Note You need to log in before you can comment on or make changes to this bug.