Bug 496051 - ati radeon - corrupted screen for 3D (glxgears, compiz) as of 8 Apr 2009
ati radeon - corrupted screen for 3D (glxgears, compiz) as of 8 Apr 2009
Status: CLOSED DUPLICATE of bug 494737
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 06:11 EDT by Nigel Jones
Modified: 2009-09-06 02:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 02:22:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
basic xorg.conf for dual screen (1.57 KB, text/plain)
2009-04-20 09:02 EDT, Nigel Jones
no flags Details
X output including stacktrace (292.70 KB, text/plain)
2009-04-20 09:02 EDT, Nigel Jones
no flags Details

  None (edit)
Description Nigel Jones 2009-04-16 06:11:20 EDT
Description of problem:

Regression as of ~ 08 April 2009:

WHen compiz enabled I now get a corrupted yellow/white set of lines on my desktop -- which is unusable. compiz must be disabled.

This is with latest rawhide updates

kernel-PAE-2.6.29.1-85.fc11.i686
libdrm-2.4.6-4.fc11.i586
xorg-x11-drv-ati-6.12.2-2.fc11.i586
mesa-libGL-7.5-0.9.fc11.i586


but originally occured back around 8 April at which time I had:

//excert from email
Sure the *current* versions I have are:

kernel-PAE-2.6.29.1-54.fc11.i686
libdrm-2.4.6-3.fc11.i586
xorg-x11-drv-ati-6.12.1-9.fc11.i586
mesa-libGL-7.5-0.8.fc11.i586

Previously it would have been working with
kernel-PAE-2.6.29.1-46.fc11.i686
libdrm-2.4.5-3.fc11.i586
xorg-x11-drv-ati-6.12.1-2.fc11.i586
mesa-libGL-7.5-0.6.fc11.i586


I originally had slightly earlier versions including the -52 kernel and .5 mesa as pulled from the rawhide repo -- and then fetched the latest koiji when I saw things broken.

glxgears is broken too.
//end

original email documenting problem on 08/04/2009:

 I've been using compiz for a fair amount of the time since F11 alpha, and tracking RH updates on my T60p (V5200) system. kms disabled.

 I noticed that in the last few days the radeon/mesa/kernel/drm driver updates have involved some API changes so I suspect you may be doing a slightly disruptive change?

I've seen compiz seemingly break now -- once started my screen is corrupted yellow/green lines (unusable) . without compiz its fine.

The change has been somewhere between the -46 kernel and latest compatible ati/libdrm and the -52 update, and continues with the current koiji levels as of a few hours ago.
Comment 1 Matěj Cepl 2009-04-20 05:52:05 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Nigel Jones 2009-04-20 08:37:59 EDT
I just upgraded to latest:

kernel-PAE 2.6.29.1-100
xorg-x11-drv-ati 6.12.2-4
libdrm 2.4.6-6
mesa-libGB 7.5.0.11

and I no longer get the broken compiz / glxgears.

However whilst X can be used all day with compiz disabled, having this (or other 3d apps) active introduces instability -- randomly X will "die".

Can't see anything in kernel log, but (new) error in Xorg.0.log.old is

r300_dri.so(radeonRefillCurrentDmaRegion+0x13d) [0x59b731].

this is a new error

Will restart failing box, check koji, reset xorg.conf, capture log and add as attachment/comment
Comment 3 Nigel Jones 2009-04-20 09:02:06 EDT
Created attachment 340338 [details]
basic xorg.conf for dual screen
Comment 4 Nigel Jones 2009-04-20 09:02:45 EDT
Created attachment 340339 [details]
X output including stacktrace
Comment 5 Nigel Jones 2009-04-20 09:04:17 EDT
checked koji -- no relevant updates it seems (just kernel -101). Have gone back to compiz disabled for now.
Comment 6 Otto Rey 2009-04-28 00:42:25 EDT
- fusion-icon: kill my X server (i will file another bug)
- compiz-manager or desktop effects: got a graphic corruption like no screen repaint scrolling in nautilus, firefox and others

xorg-x11-drv-ati-6.12.2-6.fc11.x86_64
kernel-2.6.29.1-102.fc11.x86_64
compiz-0.7.8-18.fc11.x86_64
fusion-icon-0.1.0-0.6.5e2dc9git.fc11.noarch
compiz-manager-0.6.0-9.fc11.noarch

01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]

No xorg.conf file
Comment 7 Nigel Jones 2009-04-28 01:28:45 EDT
Otto -- I think the -6 build was a bad one. It was unusable (even without compiz/3d) so I backed off to -4. I then saw -7 on koji which appears to fix the issue (a fix was backed off).

Reminds me I need to retest -7 for this original problem.
Comment 8 Nigel Jones 2009-04-28 01:29:46 EDT
In case you need a link:
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

I see -8 is now there. I'm using -7.
Comment 9 Jeremy Huddleston 2009-04-30 12:51:37 EDT
This is a dupe of bug #494737

It's fixed in 7.5-0.13
Comment 10 Nigel Jones 2009-05-14 15:00:04 EDT
Yes fixed. can be closed.
Comment 11 Bug Zapper 2009-06-09 09:54:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Vedran Miletić 2009-09-06 02:22:46 EDT
Closing per comment #9.

*** This bug has been marked as a duplicate of bug 494737 ***

Note You need to log in before you can comment on or make changes to this bug.