Bug 494737 - [ATI r300] render corruption mesa 7.5-0.7 kernel 2.6.29.1-52.fc11
[ATI r300] render corruption mesa 7.5-0.7 kernel 2.6.29.1-52.fc11
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
11
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 495000 496051 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 18:44 EDT by Jeremy Huddleston
Modified: 2009-09-06 02:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 02:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg.txt (28.85 KB, text/plain)
2009-04-10 21:16 EDT, Jeremy Huddleston
no flags Details
glxgears.png (8.09 KB, image/png)
2009-04-10 21:17 EDT, Jeremy Huddleston
no flags Details
Xorg.0.log (70.95 KB, text/plain)
2009-04-10 21:17 EDT, Jeremy Huddleston
no flags Details
Xorg.0.log - 0.6 mesa version (working) (67.73 KB, text/plain)
2009-04-11 05:04 EDT, Jeremy Huddleston
no flags Details

  None (edit)
Description Jeremy Huddleston 2009-04-07 18:44:55 EDT
Description of problem:

There is image corruption using the latest rawhide mesa builds

Version-Release number of selected component (if applicable):
7.5-0.8 = buggy
7.5-0.7 = buggy
7.5-0.6 = correct

How reproducible:
100% on my system: 

kernel-2.6.29.1-46.fc11.ppc
xorg-x11-drv-ati-6.12.1-9.fc11.ppc
libdrm-2.4.5-3.fc11.ppc

0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] (prog-if 00 [VGA controller])
	Subsystem: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
	Flags: bus master, 66MHz, medium devsel, latency 255, IRQ 48
	Memory at b8000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 0400 [size=256]
	Memory at b0000000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at f1000000 [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2
	Kernel driver in use: radeonfb
Comment 1 François Cami 2009-04-10 19:45:10 EDT
    Hi Jeremy,

    Could you be more specific about the corruption, what you are doing, etc ?
Screenshots would be nice, if at all possible.

    Please attach your X server config file (/etc/X11/xorg.conf), X server log file (/var/log/Xorg.*.log) and the output of "dmesg" to the bug report as
individual uncompressed text/plain file attachments.

    Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please. 

    Please try the nomodeset kernel parameter at boot to see if it improves things, and include dmesg and /var/log/Xorg.0.log from this attempt as well.

    We will review this issue again once you've had a chance to attach this information. 

    Thank you in advance. 

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Jeremy Huddleston 2009-04-10 21:16:33 EDT
Created attachment 339145 [details]
dmesg.txt
Comment 3 Jeremy Huddleston 2009-04-10 21:17:08 EDT
Created attachment 339146 [details]
glxgears.png
Comment 4 Jeremy Huddleston 2009-04-10 21:17:29 EDT
Created attachment 339147 [details]
Xorg.0.log
Comment 5 Jeremy Huddleston 2009-04-10 21:17:45 EDT
I don't use an xorg.conf
Comment 6 François Cami 2009-04-11 04:51:36 EDT
Jeremy, 

Could you attach Xorg.0.log with mesa 7.5-0.6 as well ?

Thank you

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Jeremy Huddleston 2009-04-11 05:04:50 EDT
Created attachment 339159 [details]
Xorg.0.log - 0.6 mesa version (working)
Comment 8 François Cami 2009-04-11 05:41:29 EDT
Thank you Jeremy.

Switching to ASSIGNED.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Jeremy Huddleston 2009-04-24 20:37:03 EDT
*** Bug 495000 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Huddleston 2009-04-29 02:39:31 EDT
I installed mesa-7.5-0.13 packages and this problem went away.  I tested with the kernel-2.6.29.1-{46,111} packages.
Comment 11 Bug Zapper 2009-06-09 09:27:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Vedran Miletić 2009-09-06 02:22:46 EDT
*** Bug 496051 has been marked as a duplicate of this bug. ***
Comment 13 Vedran Miletić 2009-09-06 02:23:25 EDT
Closing per comment #10.

Note You need to log in before you can comment on or make changes to this bug.