Bug 496151 - ISE after any package install on rhel5 client, package install succeeds though
ISE after any package install on rhel5 client, package install succeeds though
Status: CLOSED DUPLICATE of bug 485532
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
na
: Reopened
: 495740 496164 (view as bug list)
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-04-16 16:47 EDT by wes hayutin
Modified: 2009-08-05 10:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 17:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-04-16 16:47:09 EDT
Description of problem:

4/14 rhel 5 server

ISE after any package install on rhel5 client, package install succeeds though
recreate:

1. register a rhel5u3 client
2. install a package

getting ISE

D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))
D: Sending back response (0, 'Update Succeeded', {})
An error has occurred:
Internal Server Error
See /var/log/up2date for more information
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))
[root@rlx-3-06 ~]# 

/var/log/http/error.log

ceback (most recent call last):
[Thu Apr 16 15:56:00 2009] [error] [client 10.10.76.189] PythonLogHandler server.apacheServer::LogHandler:   F
ile "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 287, in HandlerDispatch\n    log=debug)
[Thu Apr 16 15:56:00 2009] [error] [client 10.10.76.189] PythonLogHandler server.apacheServer::LogHandler:   F
ile "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 461, in import_module\n    f, p, d = imp.fin
d_module(parts[i], path)
[Thu Apr 16 15:56:00 2009] [error] [client 10.10.76.189] PythonLogHandler server.apacheServer::LogHandler: Imp
ortError: No module named apacheServer
[Thu Apr 16 15:56:00 2009] [error] [client 10.10.76.189] PythonCleanupHandler server.apacheServer::CleanupHand
ler: Traceback (most recent call last):
[Thu Apr 16 15:56:00 2009] [error] [client 10.10.76.189] PythonCleanupHandler server.apacheServer::CleanupHand
ler:   File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 287, in HandlerDispatch\n    log=deb
ug)
[Thu Apr 16 15:56:00 2009] [error] [client 10.10.76.189] PythonCleanupHandler server.apacheServer::CleanupHand
ler:   File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 461, in import_module\n    f, p, d =
 imp.find_module(parts[i], path)
[Thu Apr 16 15:56:00 2009] [error] [client 10.10.76.189] PythonCleanupHandler server.apacheServer::CleanupHand
ler: ImportError: No module named apacheServer
Comment 1 wes hayutin 2009-04-16 17:01:16 EDT
fyi.. this rhel 5 client was kickstarted using satellite, which *may* be part of the recreate
Comment 2 Steve Salevan 2009-04-16 18:09:19 EDT
*** Bug 496164 has been marked as a duplicate of this bug. ***
Comment 3 Steve Salevan 2009-04-16 18:13:49 EDT
I think that Wes and I found the same bug here and, from our testing, we think that this problem is broader than the reported issue regarding package installs. 

Simply put, any call to the /XMLRPC handler on the Satellite will deterministically receive either a 500 ISE error or a successful completion of the call, including package installs and system registration, with the tracebacks Wes reported appearing in /var/log/httpd/error_log upon each ISE.
Comment 5 Devan Goodwin 2009-04-20 13:52:49 EDT
*** Bug 495740 has been marked as a duplicate of this bug. ***
Comment 6 Steve Salevan 2009-04-22 12:52:07 EDT
Try as we may, QA can't get a reproducer on this bug despite countless attempts over the past week.  It looks like this might have been a fluke, existing on our Satellite alone, so I talked with Prad, and we're going to close this as NOTABUG.  If someone ends up seeing it again, though, feel free to pop this bug open again.
Comment 7 Steve Salevan 2009-04-22 17:54:15 EDT
Reopening...  we have been able to reproduce this bug by issuing a large number of requests to Perl-related pages in the UI while kickstarting (which require Apache to be served).  See bz#485532 for more details, as this seems to be a duplicate of that.
Comment 8 Steve Salevan 2009-04-22 17:54:29 EDT

*** This bug has been marked as a duplicate of bug 485532 ***

Note You need to log in before you can comment on or make changes to this bug.