Bug 496164 - 500 ISE errors occur deterministically when accessing /XMLRPC handler
500 ISE errors occur deterministically when accessing /XMLRPC handler
Status: CLOSED DUPLICATE of bug 496151
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 17:54 EDT by Steve Salevan
Modified: 2009-04-17 11:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 18:09:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-04-16 17:54:19 EDT
Description of problem:
If a client registered to a Satellite accesses any of the functionality located at http(s)://<FQDN>/XMLRPC, they will alternatively receive either a 500 ISE message or the correct behavior.

When a 500 ISE is received, they will discover several Python tracebacks located in /var/log/httpd/error_log on the Satellite (which are attached to this bug) and the following traceback in /var/log/up2date on the client:

Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 316, in ?
    cli.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_check", line 64, in main
    self.__run_remote_actions()
  File "/usr/sbin/rhn_check", line 109, in __run_remote_actions
    action = self.__get_action(status_report)
  File "/usr/sbin/rhn_check", line 72, in __get_action
    ACTION_VERSION, status_report)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 38, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 323, in _request
    raise pe
xmlrpclib.ProtocolError: <ProtocolError for FQDN /XMLRPC: 500 Internal Server Error>

Though this problem was discovered on a RHEL4-based Satellite, it was also present on a RHEL5-based Satellite.

Version-Release number of selected component (if applicable):
530, 4/14 build, RHEL4

How reproducible:
Deterministic

Steps to Reproduce:
1. Register a RHEL client to a 530 Satellite with a -vvvvv option tagged on to rhnreg_ks...  monitor it for ISEs
2. Run rhn_check in a loop
  
Actual results:
rhn_check succeeds at times and fails at times with 500 ISE errors, ISE errors are sometimes present upon registration

Expected results:
rhn_check succeeds at all times

Additional info:
Comment 2 Steve Salevan 2009-04-16 18:09:19 EDT

*** This bug has been marked as a duplicate of bug 496151 ***

Note You need to log in before you can comment on or make changes to this bug.