Bug 49620 - sidebar panel white font in red hat theme hard to read
sidebar panel white font in red hat theme hard to read
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: nautilus (Show other bugs)
1.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
: FutureFeature
: 49752 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-21 14:51 EDT by tom georgoulias
Modified: 2007-03-26 23:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 12:00:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tom georgoulias 2001-07-21 14:51:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.2) Gecko/20010710

Description of problem:
The white font in the sidebar panels of the red hat linux theme is hard to
read against the light grey background.  I suggest it is changed to a black
font.

How reproducible:
Always

Steps to Reproduce:
1.  Start nautilus
2. Use Red Hat Linux (default) theme.
3.  Minimize all tab sidebar windows to view file information.
	

Actual Results:  Font is white on a light grey background.

Expected Results:  Font should be black on a light grey background.

Additional info:
Comment 1 Havoc Pennington 2001-07-22 17:55:55 EDT
I agree, the font color here is actually chosen dynamically to contrast with the
background; if you open "backgrounds and emblems" and manually drag the
Apparition or Silver color into the sidebar, then nautilus correctly uses a
black font. I think it just fails to properly choose the font color when the
window is first opened.
Comment 2 Havoc Pennington 2001-07-23 15:02:21 EDT
*** Bug 49752 has been marked as a duplicate of this bug. ***
Comment 3 tom georgoulias 2001-07-23 20:30:53 EDT
I verified that dragging the apparition color over the panel does indeed change
the font color to black, but it only changes the side panel for that directory.
 Moving to another directory still results in a white font.

Since you said this is drawn dynamically, might I be better off filing this
report in the nautilus bug database?
Comment 4 Havoc Pennington 2001-08-01 16:41:42 EDT
Will be in the next Nautilus package. The problem was that the default Nautilus
theme hardcoded the color, overriding the autoselection.

Note You need to log in before you can comment on or make changes to this bug.