This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 496259 - deleting all managed errata does not finish successfully
deleting all managed errata does not finish successfully
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
https://dhcp77-141.rhndev.redhat.com/...
: Reopened
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-04-17 10:56 EDT by wes hayutin
Modified: 2009-09-10 16:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:35:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-04-17 10:56:44 EDT
Description of problem:
4/14 rhel 4 server


recreate:
1. sync rhel 4 / 5 channels
2. errata -> managed 
3. select all
4. delete selected errata ( which could be about 1500 items)


get

 We're sorry, but the erratum could not be found.

This error may have occurred in one of three ways:

   1. The erratum requested does not exist. This is most likely if you arrived at this page through bookmarks or some other non-hyperlink.
   2. You do not have permission to view this erratum.
   3. You've found an error in our site. Please help us by filling out this form with details of how you received this message.
Comment 1 Brandon Perkins 2009-04-21 11:34:59 EDT
Following the instructions, Cliff and I cannot reproduce.  Please reopen with additional information if you can still reproduce it.
Comment 2 wes hayutin 2009-04-22 15:39:39 EDT
I would certainly disagree ;)   

recreate:
1. sync rhel 4 / 5 channels
2. errata -> managed 
3. select all
4. delete selected errata ( which could be about 1500 items)


4/20 build after twenty minutes, never returns 
java process > 100% looking at top.
Comment 3 Brandon Perkins 2009-04-23 10:55:04 EDT
Comment #2 says that the procedure doesn't return, but the summary of this bug is about a 404, which we never saw.  If the issue is the not returning, please modify the summary to match what you are seeing.
Comment 4 wes hayutin 2009-04-23 11:10:02 EDT
on rhel 4, 4/14 build the transaction would finish and load the wrong page at the end.  The page load was an errata not found page.

on rhel5 on 4/20 the transaction never completes
Comment 5 Clifford Perry 2009-04-24 11:46:53 EDT
Since unable to reproduce the 404 but the never completes. Approved. 

Possible dupe of bug 497458

Cliff
Comment 6 Justin Sherrill 2009-04-27 15:36:34 EDT
d7b4797 

Deleting about 1500 errata should take about 25 seconds now, vs 10-20 minutes we were seeing before.

I modified everything to use bulk queries instead of queries for each errata.  

So instead of running 6 queries 1500 times, it just runs them once.
Comment 7 wes hayutin 2009-05-28 12:46:19 EDT
verified 5/21.1
Comment 8 Preethi Thomas 2009-08-04 11:32:22 EDT
Release Pending
Deleting all managed errata completed on test1182.test.redhat.com
Comment 9 Brandon Perkins 2009-09-10 16:35:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.