Bug 496333 - M22 / Radeon X300 dual display doesn't work with KMS
M22 / Radeon X300 dual display doesn't work with KMS
Status: CLOSED DUPLICATE of bug 521161
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 17:07 EDT by Mads Kiilerich
Modified: 2018-04-11 15:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 07:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (31.66 KB, text/plain)
2009-04-17 17:07 EDT, Mads Kiilerich
no flags Details
X log (253.13 KB, text/plain)
2009-04-17 17:09 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-04-17 17:07:19 EDT
Created attachment 340087 [details]
dmesg

Description of problem:

http://www.smolts.org/client/show/pub_39aac23f-48cc-4fae-98a8-70f2aa0fb15e
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]

Dual display works fine without KMS.

With KMS one of the displays shows noise. Initially (in gdm with mirrored displays) the laptops own display is fine while the external display is corrupted. When I log in and my display settings are applied the external screen (which I use as primary) is fine while the laptops display is corrupted.

Initially the noise was pure digital (as if wrong memory areas had been mapped), but later it also showed psycedelic fading colors.


Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.12.2-2.fc11.i586
kernel-PAE-2.6.29.1-70.fc11.i686
Comment 1 Mads Kiilerich 2009-04-17 17:09:33 EDT
Created attachment 340089 [details]
X log

Plenty of 
(EE) RADEON(0): ADVANCE_RING count != expected (14 vs 16) at radeon_textured_videofuncs.c:1623
Comment 2 Mads Kiilerich 2009-04-17 17:10:29 EDT
Forgot to say that the displays were correctly mirrored during boot, until X started
Comment 3 Mads Kiilerich 2009-04-26 21:06:56 EDT
With kernel-PAE-2.6.29.1-102.fc11.i686 and KMS and no external display I get psycedelic fading colors on the internal display. The only solution is to reboot and use nomodeset.

I think this almost qualifies as a f11 blocker?
Comment 4 Bug Zapper 2009-06-09 10:02:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Mads Kiilerich 2009-10-14 07:06:28 EDT
The machine has been upgraded to Fedora 12, so I can't/won't test this. But apparently similar problems are seen in Fedora 12 and reported in bug 521161.

*** This bug has been marked as a duplicate of bug 521161 ***

Note You need to log in before you can comment on or make changes to this bug.