Bug 521161 - nomodeset:RV370|M22:X300 hangs,redraw errors,resume fails
nomodeset:RV370|M22:X300 hangs,redraw errors,resume fails
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 496333 501140 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-03 19:31 EDT by Mads Kiilerich
Modified: 2010-01-14 16:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-13 17:55:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (51.91 KB, text/plain)
2009-09-03 19:31 EDT, Mads Kiilerich
no flags Details
X log (67.78 KB, text/plain)
2009-09-03 19:32 EDT, Mads Kiilerich
no flags Details
dmesg from 2.6.31-0.204.rc9.fc12.i686.PAE with KMS (and thus unusable display) (33.43 KB, text/plain)
2009-09-06 18:33 EDT, Mads Kiilerich
no flags Details
Redraw problems in gnome-terminal tab titles (12.86 KB, image/png)
2009-11-23 08:02 EST, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-09-03 19:31:03 EDT
Created attachment 359739 [details]
dmesg

Description of problem:

After upgrading to Fedora 12 / rawhide my laptop crashes regularly. It usually happens when some "heavy" redraw operations happens. Usually when switching to Firefox.

I regularly see redraw errors - especially white lines in firefox tab titles and dropouts of text in gnometerminal. 

I am running nomodeset because booting with KMS doesn't work - it gives "fading psycedelic colors" when KMS kicks in (reported for Fedora 11 at bug 496333).

Once when the machine was hanging I also saw the colors faded away.

Suspend/resume worked fine with Fedora 11 (nomodeset). With Fedora 12 the display stays black. It seems like it keeps running for some time (caps lock toggles and text console "find /" activates hd), but later it hangs. (I have however seen "possible circular locking dependency" messages, bug 519536.)

I assume that these issues are related and most of them really not interessting because KMS is the way to go and should be fixed first.

Please let me know if I can help test or provide more information.


Version-Release number of selected component (if applicable):

kernel-PAE-2.6.31-0.199.rc8.git2.fc12.i686
xorg-x11-drv-ati-6.13.0-0.2.20090821gitb1b77a4d6.fc12.i686

01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]

http://www.smolts.org/client/show/pub_6ee23250-8a78-44b8-a4ec-9a0b999ebbe1
Comment 1 Mads Kiilerich 2009-09-03 19:32:30 EDT
Created attachment 359740 [details]
X log

X log - probably not that relevant
Comment 2 Mads Kiilerich 2009-09-06 18:33:10 EDT
Created attachment 359933 [details]
dmesg from 2.6.31-0.204.rc9.fc12.i686.PAE with KMS (and thus unusable display)

As suggested by nanonyme:
dmesg from 2.6.31-0.204.rc9.fc12.i686.PAE with KMS (and thus unusable display)

He also noted that nomodeset X had
(EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.
- but I suggest focussing on making KMS work first.
Comment 3 Mads Kiilerich 2009-10-14 06:58:38 EDT
*** Bug 501140 has been marked as a duplicate of this bug. ***
Comment 4 Jérôme Glisse 2009-10-14 07:01:50 EDT
Do you still have issue with lastest fedora 12 kernel ?
Comment 5 Mads Kiilerich 2009-10-14 07:06:28 EDT
*** Bug 496333 has been marked as a duplicate of this bug. ***
Comment 6 Mads Kiilerich 2009-10-14 07:26:17 EDT
Re comment 4:

Yes, I generally use the latest kernels and still see the issues. 

Of course I work around them by
- not using KMS
- not suspending (fortunately hibernate (suspend-to-disk) has started to work)
- ignoring redraw errors
- restart when it hangs
(- and as en extra bonus I have bug 528390 ;-)

Should I test something in a specific kernel version?
Comment 7 Jérôme Glisse 2009-11-12 10:33:56 EST
So to sumup KMS:

- computer hangs after a while, mostly when "heavily" using firefox
- suspend/resume is broken

For suspend resume i suspect that :
https://bugzilla.redhat.com/show_bug.cgi?id=519536
is the root cause of the issue. Can you login on the computer through ssh after resume (wait a bit to give time for network to comeback) ?
Comment 8 Mads Kiilerich 2009-11-12 10:51:00 EST
No, the KMS sumup is:
KMS doesn't work - it gives "fading psycedelic colors" when KMS kicks in (reported for Fedora 11 at bug 496333).

The issues I correlate with firefox might of course be bug 528390. I have only seen few hangs where I was sure firefox wasn't involved.

I will retest suspend/resume ASAP and see if 2.6.31.5-121 has helped.

Thanks for looking into this. Sorry for the messy report, but I'm not sure these issues can be separated.
Comment 9 Jérôme Glisse 2009-11-12 13:33:59 EST
Please test with KMS enabled. Do you have a bug open for your KMS issue ? If you don't i suggest to open one and i will switch this one to UMS. Right now we are focussing on fixing KMS as it's were we want to go.
Comment 10 Mads Kiilerich 2009-11-22 10:47:32 EST
Re comment #9: 
I have created 540139 for the KMS issue, so what is left here is nomodeset issues:
- X crashes (probably bug 528390, mostly avoidable with care)
- redraw errors (not every day, but regularly seen on tortoisehg logs, alt-tab or mouse-hoovering often helps)
- resume after suspend hangs (hibernate-to-disk works as a workaround)


Re comment #7: 
(See also bug 519536)

With kernel-PAE-2.6.31.6-145.fc12.i686 nomodeset (latest from koji) resume doesn't even get as far as this issue. 

It locks up really hard: Resuming turns the display on, but nothing is written to /var/log/messages, apparently no disc activity, no reaction to caps-lock, ctrl-alt-f2 ctrl-alt-del does nothing, only a hard power off works.
(I don't have another machine easily available for ssh'ing, but I assume that the description above is enough?)
Comment 11 Sam Stelfox 2009-11-22 15:40:44 EST
I am having similar issues, after consulting the common fedora 12 bugs it suggested posting a report on bug #498457 but this one seemed closer to the problems I was having.

I am running a dual desktop display with an ATI RV370. I have had no lockups of X but there are a lot of redraw artifacts. I can get most of them to go away for a particular window by minimizing it and bringing it back. Following the suggestions of the Fedora 12 common bugs page I added 'nomodeset' to my kernel parameters and so far that seems to have resolved the issue.

Before I added 'nomodeset' the most common applications to see the issues with was thunderbird and firefox. It would also happen when loading up KDE after login when I was using gdm. Switching to kdm+kde seems to have resolved that issue before I started using 'nomodeset'. I guess this could be a separate bug but figured the more information the better.

I dont ever suspend/resume my computer so I do not know how it would handle that.

I am happy to provide any logs or files requested, and will perform any test on my system that is requested.

Good luck to all those hard working developers out there :)
Comment 12 Mads Kiilerich 2009-11-23 08:02:32 EST
Created attachment 373099 [details]
Redraw problems in gnome-terminal tab titles

The crash problem might be solved with xorg-x11-drv-ati-6.13.0-0.12.20091119git437113124.fc12.i686, but I just verified that the redraw problems also remains.
Comment 13 Mads Kiilerich 2009-11-23 10:12:40 EST
I just reported a hang on bug 540511. So the hangs and the crashes I have mentioned here might be different issues.
Comment 14 Mads Kiilerich 2009-12-02 18:31:05 EST
xorg-x11-drv-ati-6.13.0-0.15.20091127gita8dbf7c23 without XAA still shows the redraw problems shown in comment #12.

Using 'Option "AccelMethod" "XAA"' in xorg.conf as described on https://fedoraproject.org/wiki/Common_F12_bugs#radeon-misc-gfx solves the redraw problems (and the firefox crashes and gives better vlc performance, but it doesn't solve resume).
Comment 15 Mads Kiilerich 2010-01-13 17:55:59 EST
With 
kernel-PAE-2.6.32.3-24.fc12.i686
xorg-x11-drv-ati-6.13.0-0.20.20091221git4b05c47ac.fc12.i686

- KMS works
- suspend/resume works
- no redrawerrors so far
- no hangs so far
- fine performance and stability without XAA hack

The situation has changed so much that if I see similar problems again I will file a new report. 

Closing.
Comment 16 Mads Kiilerich 2010-01-14 16:54:31 EST
Update: I do see corruption now - probably bug 529081.

Note You need to log in before you can comment on or make changes to this bug.