Bug 496382 - Crashes, and takes over session on restart
Crashes, and takes over session on restart
Status: CLOSED DUPLICATE of bug 496234
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-04-18 09:14 EDT by Bastien Nocera
Modified: 2015-01-14 18:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 09:23:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2009-04-18 09:14:07 EDT
I found my "session logs me out" problem. GDM crashes and starts on a new VT. This also seems to confuse the hell out of ConsoleKit which then thinks that I'm not logged in anymore (ck-list-sessions just lists gdm as logged in).

root                  Session4   Seat1   tty2                          Sat Apr 18 14:04   still logged in   
gdm       LoginWindow Session3   Seat1   :1                            Sat Apr 18 14:04   still logged in   
hadess                Session2   Seat1   :0                            Sat Apr 18 13:54 - 14:04  (00:10)    
gdm       LoginWindow Session1   Seat1   :0                            Sat Apr 18 13:53 - 13:54  (00:01)    

But I'm still logged in at 14:13...

ConsoleKit-0.3.0-7.fc11.i586
gdm-2.26.1-1.fc11.i586

Apr 18 14:04:16 snoogens gdm[3649]: ******************* START **********************************
Apr 18 14:04:22 snoogens gdm[3649]: 0x00686422 in __kernel_vsyscall ()
Apr 18 14:04:22 snoogens gdm[3649]: #0  0x00686422 in __kernel_vsyscall ()
Apr 18 14:04:22 snoogens gdm[3649]: #1  0x009305c3 in __waitpid_nocancel () from /lib/libc.so.6
Apr 18 14:04:22 snoogens gdm[3649]: #2  0x080668c9 in ?? ()
Apr 18 14:04:22 snoogens gdm[3649]: #3  0x080669c1 in ?? ()
Apr 18 14:04:22 snoogens gdm[3649]: #4  <signal handler called>
Apr 18 14:04:22 snoogens gdm[3649]: #5  0x08059ddc in endutxent ()
Apr 18 14:04:22 snoogens gdm[3649]: #6  0x0805a4ce in endutxent ()
Apr 18 14:04:24 snoogens gdm[3649]: #7  0x00170923 in _dbus_object_tree_dispatch_and_unlock (tree=0x8a5f360, 
Apr 18 14:04:24 snoogens gdm[3649]:     message=0x8a67f18) at dbus-object-tree.c:856
Apr 18 14:04:24 snoogens gdm[3649]: #8  0x001639bc in dbus_connection_dispatch (connection=0x8a5f1b0)
Apr 18 14:04:24 snoogens gdm[3649]:     at dbus-connection.c:4447
Apr 18 14:04:24 snoogens gdm[3649]: #9  0x0010d19d in message_queue_dispatch (source=0x8a5ee10, callback=0, 
Apr 18 14:04:24 snoogens gdm[3649]:     user_data=0x0) at dbus-gmain.c:101
Apr 18 14:04:24 snoogens gdm[3649]: #10 0x003cc1e8 in g_main_dispatch (context=<value optimized out>)
Apr 18 14:04:24 snoogens gdm[3649]:     at gmain.c:1814
Apr 18 14:04:24 snoogens gdm[3649]: #11 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2367
Apr 18 14:04:24 snoogens gdm[3649]: #12 0x003cf7f8 in g_main_context_iterate (context=0x8a3a598, 
Apr 18 14:04:24 snoogens gdm[3649]:     block=<value optimized out>, dispatch=1, self=0x8a37760) at gmain.c:2448
Apr 18 14:04:24 snoogens gdm[3649]: #13 0x003cfcaf in IA__g_main_loop_run (loop=0x8a3daa8) at gmain.c:2656
Apr 18 14:04:24 snoogens gdm[3649]: #14 0x0804d2df in endutxent ()
Apr 18 14:04:24 snoogens gdm[3649]: #15 0x008a88e6 in __libc_start_main () from /lib/libc.so.6
Apr 18 14:04:24 snoogens gdm[3649]: #16 0x0804ced1 in endutxent ()
Apr 18 14:04:24 snoogens gdm[3649]: 
Apr 18 14:04:24 snoogens gdm[3649]: Thread 1 (process 2870):
Apr 18 14:04:24 snoogens gdm[3649]: #0  0x00686422 in __kernel_vsyscall ()
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: #1  0x009305c3 in __waitpid_nocancel () from /lib/libc.so.6
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: #2  0x080668c9 in ?? ()
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: #3  0x080669c1 in ?? ()
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: #4  <signal handler called>
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: #5  0x08059ddc in endutxent ()
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: #6  0x0805a4ce in endutxent ()
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: #7  0x00170923 in _dbus_object_tree_dispatch_and_unlock (tree=0x8a5f360, 
Apr 18 14:04:24 snoogens gdm[3649]:     message=0x8a67f18) at dbus-object-tree.c:856
Apr 18 14:04:24 snoogens gdm[3649]:         user_data = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]:         next = 0x0
Apr 18 14:04:24 snoogens gdm[3649]:         path = 0x8a43960
Apr 18 14:04:24 snoogens gdm[3649]: 
Apr 18 14:04:24 snoogens gdm[3649]:         list = 0x8a60878
Apr 18 14:04:24 snoogens gdm[3649]:         link = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]:         result = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]:         subtree = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]: #8  0x001639bc in dbus_connection_dispatch (connection=0x8a5f1b0)
Apr 18 14:04:24 snoogens gdm[3649]:     at dbus-connection.c:4447
Apr 18 14:04:24 snoogens gdm[3649]:         message = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]:         link = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]:         filter_list_copy = 0x0
Apr 18 14:04:24 snoogens gdm[3649]:         message_link = 0x8a60884
Apr 18 14:04:24 snoogens gdm[3649]:         result = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]:         status = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]: 
Apr 18 14:04:24 snoogens gdm[3649]: #9  0x0010d19d in message_queue_dispatch (source=0x8a5ee10, callback=0, 
Apr 18 14:04:24 snoogens gdm[3649]:     user_data=0x0) at dbus-gmain.c:101
Apr 18 14:04:24 snoogens gdm[3649]:         connection = 0x8a5f1b0
Apr 18 14:04:24 snoogens gdm[3649]: #10 0x003cc1e8 in g_main_dispatch (context=<value optimized out>)
Apr 18 14:04:24 snoogens gdm[3649]:     at gmain.c:1814
Apr 18 14:04:24 snoogens gdm[3649]:         dispatch = 0x10d170 <message_queue_dispatch>
Apr 18 14:04:24 snoogens gdm[3649]:         user_data = 0x0
Apr 18 14:04:24 snoogens gdm[3649]:         callback = 0
Apr 18 14:04:24 snoogens gdm[3649]:         cb_funcs = 0x0
Apr 18 14:04:24 snoogens gdm[3649]:         cb_data = 0x0
Apr 18 14:04:24 snoogens gdm[3649]: next = 0x0}
Apr 18 14:04:24 snoogens gdm[3649]:         source = 0x8a5ee10
Apr 18 14:04:24 snoogens gdm[3649]:         current = 0x8a32e08
Apr 18 14:04:24 snoogens gdm[3649]: 
Apr 18 14:04:24 snoogens gdm[3649]: #11 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2367
Apr 18 14:04:24 snoogens gdm[3649]: No locals.
Apr 18 14:04:24 snoogens gdm[3649]: #12 0x003cf7f8 in g_main_context_iterate (context=0x8a3a598, 
Apr 18 14:04:24 snoogens gdm[3649]:     block=<value optimized out>, dispatch=1, self=0x8a37760) at gmain.c:2448
Apr 18 14:04:24 snoogens gdm[3649]: 
Apr 18 14:04:24 snoogens gdm[3649]: 
Apr 18 14:04:24 snoogens gdm[3649]: 
Apr 18 14:04:24 snoogens gdm[3649]:         nfds = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]:         allocated_nfds = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]:         fds = <value optimized out>
Apr 18 14:04:24 snoogens gdm[3649]: 
Apr 18 14:04:24 snoogens gdm[3649]: #13 0x003cfcaf in IA__g_main_loop_run (loop=0x8a3daa8) at gmain.c:2656
Apr 18 14:04:24 snoogens gdm[3649]:         self = 0x8a37760
Apr 18 14:04:24 snoogens gdm[3649]: 
Apr 18 14:04:24 snoogens gdm[3649]: #14 0x0804d2df in endutxent ()
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: #15 0x008a88e6 in __libc_start_main () from /lib/libc.so.6
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: #16 0x0804ced1 in endutxent ()
Apr 18 14:04:24 snoogens gdm[3649]: No symbol table info available.
Apr 18 14:04:24 snoogens gdm[3649]: The program is running.  Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]
Apr 18 14:04:24 snoogens gdm[3649]: ******************* END **********************************
Comment 1 Ray Strode [halfline] 2009-04-20 09:23:33 EDT
marking as a dupe of spot's bug.

*** This bug has been marked as a duplicate of bug 496234 ***

Note You need to log in before you can comment on or make changes to this bug.