Bug 496540 - Epiphany Configuration Making It Hang
Epiphany Configuration Making It Hang
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 21:24 EDT by das
Modified: 2013-03-13 13:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace of all threads while running epiphany (10.81 KB, text/plain)
2009-05-24 01:31 EDT, das
no flags Details
epiphany-xulrunner gdb output (13.39 KB, text/plain)
2009-05-24 10:37 EDT, das
no flags Details

  None (edit)
Description das 2009-04-19 21:24:46 EDT
Description of problem:
The browser Epiphany hangs when tried to modify configuration and it does not work before system restart.

Version-Release number of selected component (if applicable):
GNOME epiphany 2.26.1

How reproducible:
Every time

Steps to Reproduce:
1. Go to 'about:cofig' in the address field
2. Add "layout" in the 'Fiter' field
3. Go to the entry:
layout.spellcheckDefault;0
4. Select this variable and its value and right-click 'Modify'.
5. Some time will pass and there will be pop-up notice that some script is not working. Click continue.
  
Actual results:
The browser hangs. And nothing works there, in any tag till the whole system restarts (maybe restarting X could do this job, but, in this installation, due some new graphic driver for Intel DG 41 TY motherboard, it cannot go or boot to any other init than 5)

Expected results:
The variable would be modified to '1' and then fixing the 'lang' variable to the desired language will start spell-checking.

Additional info:
In fact, after I opened the 'about:config' in another tab this tab is not working too, and I have to go to another browser like galeon or firefox to enter this bug-report, because, whenever I am clicking the 'Commit' switch below it is popping up a blank dialog box with just the 'OK' highlighted and that too is not working.
Comment 1 das 2009-05-01 10:42:45 EDT
After the latest xulrunner update, another problem with Epiphany (https://bugzilla.redhat.com/show_bug.cgi?id=496549) went away, but this one persists. I tried making spell-check on in Epiphany, and so I have to report to this bug from Firefox.
Comment 2 das 2009-05-12 11:01:29 EDT
Till now spellcheck is not available on Epiphany, trying to make it available makes it hang till reboot (or maybe relogin, I am not sure).
Comment 3 das 2009-05-22 10:16:04 EDT
One tab in Epiphany was open with the gmail account, and on two other
tabs google analytics, the graphics and all there working with
flash-plugin. And when I crossed out one of the tabs, the whole
Epiphany window together with all the tabs vanished. This has happened
earlier too, quite a few times, making one tab off makes the whole
thing vanish. Though I cannot remember exactly what sites were open.

This is reproducible, because in two other cases it happened too, when google analytics pages are opened. 

And the spellcheck enabling problem is till there, trying to do it makes Epiphany hang till I reboot or restart X or relogin. Trying to enable default spellcheck is giving this message:

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.  Script: chrome://global/content/config.js:69. 

And it is giving me two options: 'Continue' and 'Stop the Script'. But whatever action I choose this is making Epiphany hang.
Comment 4 Matěj Cepl 2009-05-23 19:43:41 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please also install epiphany-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install epiphany

Then run epiphany inside of gdb (gdb epiphany). Then use command run and do whatever you did to make epiphany crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 das 2009-05-23 23:14:40 EDT
I am sorry, maybe I am missing something. There is no package called 'epiphany-debuginfo'. Here I am pasting the output of 'yum search epiphany':

<<beagle-epiphany.i586 : Beagle backend for Epiphany
epiphany.i586 : Web browser for GNOME
epiphany-devel.i586 : Support for developing extensions for the epiphany web
                    : browser
epiphany-extensions.i586 : Extensions for Epiphany, the GNOME web browser
gget-epiphany-extension.i586 : GGet extensions for epiphany
gwget-epiphany-extension.i586 : Gwget2 extensions for epiphany
swfdec-mozilla.i586 : Mozilla/Gecko player Flash plugin using swfdec>>

Though the command 'debuginfo-install epiphany' did work, it went into a 153 MB download. 

I will report what happens when this is over.
Comment 6 das 2009-05-24 01:29:40 EDT
Here is the output, I am attaching it as an uncompressed text document. I did as you said.
Comment 7 das 2009-05-24 01:31:17 EDT
Created attachment 345223 [details]
gdb backtrace of all threads while running epiphany

gdb backtrace of all threads while running epiphany.
Comment 8 das 2009-05-24 01:34:54 EDT
What I did was to open 'about:config' in a tab, and filter 'layout' and then went to the line:

layout.spellcheckDefault;0

Selected it, right-clicked and clicked 'Modify' and this created a freeze. I wanted to select click 'Modify' once again, but this time 'Modify' was not getting selected. But, unlike the other times when I ran without gdb, the 'JS not responding' screen did not come up.
Comment 9 Matěj Cepl 2009-05-24 08:28:18 EDT
(In reply to comment #5)
> I am sorry, maybe I am missing something. There is no package called
> 'epiphany-debuginfo'. Here I am pasting the output of 'yum search epiphany':

Yes, you are, I haven't asked you to install epiphany-debuginfo with plain yum because I know that most likely you don't have rawhide-debuginfo switched on, and because installing all dependent -debuginfo packages is just too hard. debuginfo-install (which is what I asked you to use) both switches on -debuginfo repository and installs all required lower level packages all the way down to glibc-debuginfo. The result is that the backtrace in comment 7 is useless, because you haven't got xulrunner-debuginfo installed, and it seems there was something interesting going on there. Also, please, paste also the last lines *before* you run the backtrace command in gdb, it says where exactly epiphany crashed.
Comment 10 das 2009-05-24 09:32:07 EDT
OK, now I am doing 'debuginfo-install xulrunner'. It is 87 MB. When it is complete I will report you back.
Comment 11 das 2009-05-24 10:37:40 EDT
Created attachment 345251 [details]
epiphany-xulrunner gdb output

epiphany-xulrunner-gdb-backtrace-all
Comment 12 das 2009-05-24 10:38:56 EDT
After 'debuginfo-install xulrunner' I did as you said. This time I gave the entire gdb output. Only one thing, I don't know if it is important, but mentioning it to be on the safeside, after the freeze in epiphany (this time the js popup window came up), the command prompt did not return in gdb, even when I crossed out the epiphany window, I had to issue 'Ctrl-c' on the gdb prompt. I am attaching the file epiphany-xulrunner-gdb-backtrace.
Comment 13 Matěj Cepl 2009-05-24 15:16:19 EDT
(In reply to comment #10)
> OK, now I am doing 'debuginfo-install xulrunner'. It is 87 MB. When it is
> complete I will report you back.  

Always look on the bright side of life ... kernel-debuginfo is 288MB and openoffice.org-debuginfo 557MB. It could be much worse ;-).

Thanks for the backtrace, looks interesting. Passing to developers.
Comment 14 das 2009-05-24 19:42:56 EDT
(In reply to comment #13)
 
> 
> Always look on the bright side of life ... kernel-debuginfo is 288MB and
> openoffice.org-debuginfo 557MB. It could be much worse ;-).
> 

Yeah, try to convince that to my niece who was watching youtube and all on a Sunday afternoon ... :(
Comment 15 Bug Zapper 2009-06-09 10:09:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2010-04-27 09:47:37 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Bug Zapper 2010-06-28 08:06:24 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.