Bug 49658 - XFree86-xfs-4.1.0-0.9.1 has corrupt /usr/X11R6/lib/X11/fonts/Type1/fonts.scale (and thus fonts.dir too)
Summary: XFree86-xfs-4.1.0-0.9.1 has corrupt /usr/X11R6/lib/X11/fonts/Type1/fonts.scal...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 52517 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-22 21:02 UTC by Jonathan Kamens
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 16:12:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to spec file to generate Type1 fonts.scale correctly (538 bytes, patch)
2001-08-21 03:01 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2001-07-22 21:02:46 UTC
When I start xfs after upgrading to 4.1.0-0.9.1, I see this in my slslog:

Font Server: ignoring font path element /usr/X11R6/lib/X11/fonts/Type1
(unreadable)

When I examine fonts.dir in that directory, I see that line 67, the first
font with a "fontspecific" encoding, starts with "40 " followed by the font
file name, rather than just the font file name.  Fonts.scale has a similar
problem -- line 67 has "40" on a line by itself.

This appears to be a bug in mkfontdir.  I am investigatint it further,
which involves downloading and compiling the source code and will therefore
take a while, but in the meantime, I thought I should file a bug report
about it.

Comment 1 Jonathan Kamens 2001-07-22 21:35:10 UTC
The base problem here is that fonts.scale in this directory is corrupt.  The
"65" in this directory should be changed to "105" and the "40" (i.e., line 67)
should be removed.

A more systemic problem is that mkfontdir didn't detect this error.  I'll file a
separate bug report about that with a patch.


Comment 2 Mike A. Harris 2001-07-25 07:37:07 UTC
Yep, fonts.scale corruption is due to an X specfile stupidity.


*** This bug has been marked as a duplicate of 49660 ***

Comment 3 Jonathan Kamens 2001-08-09 13:06:27 UTC
This is *not* a duplicate of 49660.  This bug is about the fact that the
fonts.scale file is messed up (and, incidentally, it's *still* messed up in
XFRee86-4.1.0-0.9.11; this *really* needs to be fixed before the next release). 
49660 is about the fact taht mkfontdir should have done a better job of
*detecting* the corrupt fonts.scale file.


Comment 4 Jonathan Kamens 2001-08-21 03:01:02 UTC
Doesn't this bug really need to be fixed before the next public release? 
Doens't it render all the fonts in the directory
/usr/X11R6/lib/X11/fonts/Type1/fonts.scale unusable?  Am I confused about this?

I will attach a spec file patch which I believe will fix this, although I
haven't fully tested it yet (it takes XFree86 a long time to build).


Comment 5 Jonathan Kamens 2001-08-21 03:01:52 UTC
Created attachment 28596 [details]
patch to spec file to generate Type1 fonts.scale correctly

Comment 6 Mike A. Harris 2001-08-24 19:11:45 UTC
*** Bug 52517 has been marked as a duplicate of this bug. ***

Comment 7 vrossum 2001-08-30 16:12:51 UTC
As a fix I installed 'Xfscl.tgz' directly from ftp.xfree86.org.
Works for me.

Comment 8 Mike A. Harris 2001-09-13 06:08:43 UTC
This has been fixed in rawhide for a while.  All users are encouraged
to upgrade to the latest release.


Note You need to log in before you can comment on or make changes to this bug.