Bug 496618 - bootloader.images.getDefault() returns None
bootloader.images.getDefault() returns None
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:78f4da7ca9081d413...
:
: 498466 (view as bug list)
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-04-20 07:55 EDT by Adam Pribyl
Modified: 2009-05-20 06:53 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 17:25:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (201.52 KB, text/plain)
2009-04-20 07:55 EDT, Adam Pribyl
no flags Details
Attached traceback automatically from anaconda. (102.80 KB, text/plain)
2009-04-20 13:56 EDT, Steven M. Parrish
no flags Details
Attached traceback automatically from anaconda. (264.09 KB, text/plain)
2009-04-21 13:36 EDT, Luya Tshimbalanga
no flags Details
Attached traceback automatically from anaconda. (250.38 KB, text/plain)
2009-04-24 08:24 EDT, Roman Rakus
no flags Details
Attached traceback automatically from anaconda. (146.25 KB, text/plain)
2009-04-27 11:15 EDT, idak
no flags Details
Attached traceback automatically from anaconda. (166.76 KB, text/plain)
2009-04-29 00:19 EDT, axle_foley99
no flags Details
Attached traceback automatically from anaconda. (172.88 KB, text/plain)
2009-04-29 08:01 EDT, mail
no flags Details
Attached traceback automatically from anaconda. (205.01 KB, text/plain)
2009-04-30 04:47 EDT, Niels Haase
no flags Details
Anaconda dump log (102.44 KB, text/plain)
2009-04-30 07:31 EDT, IBM Bug Proxy
no flags Details
Attached traceback automatically from anaconda. (124.97 KB, text/plain)
2009-05-02 15:21 EDT, Fabian Affolter
no flags Details
Attached traceback automatically from anaconda. (226.15 KB, text/plain)
2009-05-02 16:39 EDT, Milos Jakubicek
no flags Details
Attached traceback automatically from anaconda. (135.92 KB, text/plain)
2009-05-05 05:37 EDT, Petr Lautrbach
no flags Details
Anaconda dump log (102.44 KB, application/octet-stream)
2009-05-05 05:47 EDT, IBM Bug Proxy
no flags Details
Attached traceback automatically from anaconda. (187.35 KB, text/plain)
2009-05-20 06:44 EDT, Matthias Runge
no flags Details

  None (edit)
Description Adam Pribyl 2009-04-20 07:55:38 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.46 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1682, in getDeviceByName
    device.name == name.replace("--","-"):
  File "/usr/lib/anaconda/bootloader.py", line 149, in writeBootloader
    defaultDev = anaconda.id.storage.devicetree.getDeviceByName(anaconda.id.bootloader.images.getDefault())
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1344, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'replace'
Comment 1 Adam Pribyl 2009-04-20 07:55:46 EDT
Created attachment 340325 [details]
Attached traceback automatically from anaconda.
Comment 2 Adam Pribyl 2009-04-20 07:59:46 EDT
This is a preupgrade attempt from Fedora 8 to rawhide (I know a bit too big jump). After a while during finishing update the progress bar stopped, then this message happened. All other consoles are blank, I could not find anything more.
Comment 3 Steven M. Parrish 2009-04-20 13:56:03 EDT
Created attachment 340397 [details]
Attached traceback automatically from anaconda.
Comment 4 Luya Tshimbalanga 2009-04-21 13:36:14 EDT
Created attachment 340592 [details]
Attached traceback automatically from anaconda.
Comment 5 Chris Lumens 2009-04-23 10:33:12 EDT
What kind of partitioning layout do you have?  What do your bootloader configs look like?  Did you tell anaconda to overwrite your existing bootloader, or what?
Comment 6 Luya Tshimbalanga 2009-04-23 14:32:23 EDT
In my case, I had partition separate on four HDDs:

-sda1: Microsoft Windows XP SP3
-sdb1: Fedora 10 
-sdc1: ext2 Storage device
-sdd1: Fedora 10 (the partition on which preupgrade was set to upgrade to Rawhide)

Preupgrade 1.0.x overwrite the first Fedora partition it encounters due to its inability to only upgrade the specific partition. That bug is currently addressed on #496952.
Comment 7 Adam Pribyl 2009-04-24 08:21:29 EDT
This was anaconda started thru preupgrade process. I am not sure if there is a question about rewriting GRUB, but if yes then I for sure asked to update the grub. After this crash the grub.conf had still the "Upgrade to Rawhide" option.
That's all I can say. Here is the filesystem:

-------------------------------------------------------
fdisk -l

Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000c88cb

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        1275    10241406    c  W95 FAT32 (LBA)
/dev/sda2   *        1276        1288      104422+  83  Linux (ext3)
/dev/sda3            1289        3737    19671592+  8e  Linux LVM

Disk /dev/dm-0: 19.0 GB, 19025362944 bytes
255 heads, 63 sectors/track, 2313 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 1107 MB, 1107296256 bytes
255 heads, 63 sectors/track, 134 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-1 doesn't contain a valid partition table
-------------------------------------------------------
lvscan 
  ACTIVE            '/dev/VolGroup00/LogVol00' [17,72 GB] inherit (ext3)
  ACTIVE            '/dev/VolGroup00/LogVol01' [1,03 GB] inherit (swap)

-------------------------------------------------------
cat /etc/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,1)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/hda
default=1
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu

title Fedora (2.6.29.1-102.fc11.i586)
	root (hd0,1)
	kernel /vmlinuz-2.6.29.1-102.fc11.i586 ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=force noapic
	initrd /initrd-2.6.29.1-102.fc11.i586.img

title Fedora (2.6.29.1-102.fc11.i686.PAE)
	root (hd0,1)
	kernel /vmlinuz-2.6.29.1-102.fc11.i686.PAE ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=force noapic
	initrd /initrd-2.6.29.1-102.fc11.i686.PAE.img

title Fedora (2.6.29.1-100.fc11.i586)
	root (hd0,1)
	kernel /vmlinuz-2.6.29.1-100.fc11.i586 ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=force noapic
	initrd /initrd-2.6.29.1-100.fc11.i586.img

title Upgrade to Rawhide
	kernel /upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade stage2=http://mirror.karneval.cz/pub/linux/fedora/linux/development/i386/os/images/install.img ks=hd:UUID=ef9daa9f-d6c5-44e7-bf88-c242b8a09bb3:/upgrade/ks.cfg
	initrd /upgrade/initrd.img
title 2.6.24
	root (hd0,1)
	kernel /image-2.6.24 ro root=/dev/VolGroup00/LogVol00 acpi=force noapic 3
	initrd /initrd-2.6.24.img

title Other
	rootnoverify (hd0,0)
	chainloader +1
Comment 8 Roman Rakus 2009-04-24 08:24:52 EDT
Created attachment 341153 [details]
Attached traceback automatically from anaconda.
Comment 9 idak 2009-04-27 11:15:52 EDT
Created attachment 341444 [details]
Attached traceback automatically from anaconda.
Comment 10 axle_foley99 2009-04-29 00:19:22 EDT
Created attachment 341699 [details]
Attached traceback automatically from anaconda.
Comment 11 mail 2009-04-29 08:01:32 EDT
Created attachment 341745 [details]
Attached traceback automatically from anaconda.
Comment 12 Niels Haase 2009-04-30 04:47:32 EDT
Created attachment 341883 [details]
Attached traceback automatically from anaconda.
Comment 13 IBM Bug Proxy 2009-04-30 07:31:36 EDT
Created attachment 341907 [details]
Anaconda dump log


------- Comment on attachment From pavan.naregundi@in.ibm.com 2009-04-30 06:09 EDT-------


After installing Fedora11 Preview using the text mode. yaboot bootloader failed to install properly and was missing with  boot options.i.e, boot: prompt was not showing any boot option.

As I could not boot fedora, tried to upgrade the F11 Preview with the same version. During the upgrade anconda generated a exception as below

=======================
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1697, in getDeviceByName
    device.name == name.replace("--","-"):
  File "/usr/lib/anaconda/bootloader.py", line 149, in writeBootloader
    defaultDev = anaconda.id.storage.devicetree.getDeviceByName(anaconda.id.bootloader.images.getDefault())
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1330, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1351, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'replace'
===========================

Machine: P550
CPU Type: power5

Attaching the generated anaconda dump file
Comment 14 Chris Lumens 2009-04-30 13:11:11 EDT
*** Bug 498466 has been marked as a duplicate of this bug. ***
Comment 15 Fabian Affolter 2009-05-02 15:21:01 EDT
Created attachment 342193 [details]
Attached traceback automatically from anaconda.
Comment 16 Milos Jakubicek 2009-05-02 16:39:48 EDT
Created attachment 342198 [details]
Attached traceback automatically from anaconda.
Comment 17 Petr Lautrbach 2009-05-05 05:37:09 EDT
Created attachment 342426 [details]
Attached traceback automatically from anaconda.
Comment 18 IBM Bug Proxy 2009-05-05 05:47:17 EDT
Created attachment 342427 [details]
Anaconda dump log


------- Comment on attachment From pavan.naregundi@in.ibm.com 2009-04-30 06:09 EDT-------


After installing Fedora11 Preview using the text mode. yaboot bootloader failed to install properly and was missing with  boot options.i.e, boot: prompt was not showing any boot option.

As I could not boot fedora, tried to upgrade the F11 Preview with the same version. During the upgrade anconda generated a exception as below

=======================
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1697, in getDeviceByName
    device.name == name.replace("--","-"):
  File "/usr/lib/anaconda/bootloader.py", line 149, in writeBootloader
    defaultDev = anaconda.id.storage.devicetree.getDeviceByName(anaconda.id.bootloader.images.getDefault())
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1330, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1351, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'replace'
===========================

Machine: P550
CPU Type: power5

Attaching the generated anaconda dump file
Comment 19 Chris Lumens 2009-05-05 13:00:26 EDT
This should be fixed in the next build of anaconda.
Comment 20 Chris Lumens 2009-05-06 17:25:26 EDT
Will confirmed this as fixed over IRC.
Comment 21 IBM Bug Proxy 2009-05-18 04:33:25 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-05-18 04:20 EDT-------
Tested with latest rawhide(anaconda-11.5.0.52-1). Seems like issue is fixed.

Thanks
Pavan
Comment 22 Matthias Runge 2009-05-20 06:44:56 EDT
Created attachment 344776 [details]
Attached traceback automatically from anaconda.
Comment 23 Matthias Runge 2009-05-20 06:53:09 EDT
I'm pretty speachless, why preupgrade took this pretty old anaconda version. Anyway, install was able to boot.

Note You need to log in before you can comment on or make changes to this bug.