This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 496660 - anaconda crashes when partition order is changed
anaconda crashes when partition order is changed
Status: CLOSED DUPLICATE of bug 491754
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
anaconda_trace_hash:fcfbd00959d0e86cd...
:
Depends On: 496343
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-04-20 11:05 EDT by James Laska
Modified: 2013-09-02 02:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 496343
Environment:
Last Closed: 2009-05-14 13:54:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-04-20 11:05:12 EDT
+++ This bug was initially created as a clone of Bug #496343 +++

The following was filed automatically by anaconda:
anaconda 11.5.0.46 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/packages.py", line 144, in turnOnFilesystems
    except DeviceError as (msg, device):
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
ValueError: need more than 1 value to unpack


--- Additional comment from andreas@bawue.net on 2009-04-17 18:10:21 EDT ---

Created an attachment (id=340102)
Attached traceback automatically from anaconda.

--- Additional comment from andreas@bawue.net on 2009-04-17 18:24:58 EDT ---

Description:

During installation onto a encrypted partition anaconda crashes with the above traceback. I do believe it is rather misleading, as gotoNext() shouldn't have been called.

I do believe the problem is related to a discrepancy between encrypted block devices and real existing partitions.

Steps to reproduce:

1. Take a system with existing partitions and lots of free space at the end of the disk: e.g. sda1 already existing, to be formatted as /boot. sda2 existing NTFS partition, sda3 /boot from another installation, sda4 extended, sda5 lvm from another installation of another linux.
2. Install with default values.
3. Select partitioning scheme "Use free space"
4. Check the Encryption toggle.
5. Check review layout.
6. Delete the newly created /boot partition on sda6 and assign sda1 to be used as the boot partition.
7. Observe that the encrypted pv has correctly changed from sda7 to sda6
8. Edit the lv details. Note that it's supposed to be installed onto crypt-sda7, the former name of the pv.

After the crash, the anaconda logfile shows that createion of crypt sda7 is marked as false.

--- Additional comment from clumens@redhat.com on 2009-04-20 10:25:21 EDT ---

The real error here is hidden from a problem with exception handling, so it's not really easy to tell what's gone wrong.  I've committed a fix to the exception handling part.  After this makes it into a rawhide build, we can look at the real error and work that in a separate report.

--- Additional comment from jlaska@redhat.com on 2009-04-20 10:55:21 EDT ---

Created an attachment (id=340359)
Attached traceback automatically from anaconda.
Comment 1 Joel Andres Granados 2009-05-11 10:07:29 EDT
andreas:

Lots of changes have been done in the past month.  Does this still apply to current rawhide?  If you can reproduce with current rawdhide, can you pls send me a detailed description of you partition table setup.  'parted -l' should do just fine.
Comment 2 Chris Lumens 2009-05-14 13:54:42 EDT

*** This bug has been marked as a duplicate of bug 491754 ***

Note You need to log in before you can comment on or make changes to this bug.