Bug 496343 - anaconda crashes when partition order is changed
anaconda crashes when partition order is changed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:fcfbd00959d0e86cd...
:
: 498799 (view as bug list)
Depends On:
Blocks: 496660
  Show dependency treegraph
 
Reported: 2009-04-17 18:10 EDT by Andreas Thienemann
Modified: 2009-05-04 10:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 496660 (view as bug list)
Environment:
Last Closed: 2009-04-20 10:25:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (187.18 KB, text/plain)
2009-04-17 18:10 EDT, Andreas Thienemann
no flags Details
Attached traceback automatically from anaconda. (210.17 KB, text/plain)
2009-04-20 10:55 EDT, James Laska
no flags Details

  None (edit)
Description Andreas Thienemann 2009-04-17 18:10:04 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.45 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/packages.py", line 143, in turnOnFilesystems
    except DeviceError as (msg, device):
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
ValueError: need more than 1 value to unpack
Comment 1 Andreas Thienemann 2009-04-17 18:10:21 EDT
Created attachment 340102 [details]
Attached traceback automatically from anaconda.
Comment 2 Andreas Thienemann 2009-04-17 18:24:58 EDT
Description:

During installation onto a encrypted partition anaconda crashes with the above traceback. I do believe it is rather misleading, as gotoNext() shouldn't have been called.

I do believe the problem is related to a discrepancy between encrypted block devices and real existing partitions.

Steps to reproduce:

1. Take a system with existing partitions and lots of free space at the end of the disk: e.g. sda1 already existing, to be formatted as /boot. sda2 existing NTFS partition, sda3 /boot from another installation, sda4 extended, sda5 lvm from another installation of another linux.
2. Install with default values.
3. Select partitioning scheme "Use free space"
4. Check the Encryption toggle.
5. Check review layout.
6. Delete the newly created /boot partition on sda6 and assign sda1 to be used as the boot partition.
7. Observe that the encrypted pv has correctly changed from sda7 to sda6
8. Edit the lv details. Note that it's supposed to be installed onto crypt-sda7, the former name of the pv.

After the crash, the anaconda logfile shows that createion of crypt sda7 is marked as false.
Comment 3 Chris Lumens 2009-04-20 10:25:21 EDT
The real error here is hidden from a problem with exception handling, so it's not really easy to tell what's gone wrong.  I've committed a fix to the exception handling part.  After this makes it into a rawhide build, we can look at the real error and work that in a separate report.
Comment 4 James Laska 2009-04-20 10:55:21 EDT
Created attachment 340359 [details]
Attached traceback automatically from anaconda.
Comment 5 James Laska 2009-04-20 12:15:22 EDT
Moving the SaveToBugzilla hash from this bug to bug#496660
Comment 6 Chris Lumens 2009-05-04 10:20:16 EDT
*** Bug 498799 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.