Bug 496728 - When adding a user with freeipa this user doesn't show up in the ovirt ui
When adding a user with freeipa this user doesn't show up in the ovirt ui
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hugh Brock
:
: 478724 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 16:35 EDT by william
Modified: 2014-07-07 08:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 09:47:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description william 2009-04-20 16:35:44 EDT
Description of problem:
When adding a new user with freeipa the user does not show up in the ovirt webui.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Create user in FreeIPA
2. Login the ovirt web ui 
3. Try to create a new user but the just created user doesn't show up.
  
Actual results:


Expected results:


Additional info:

When restarting the ovirt server then it works. Looks like a caching problem.
Comment 1 Hugh Brock 2009-05-22 11:13:27 EDT
Darryl, this was working at one point, can you take a look?
Comment 2 Hugh Brock 2009-05-22 13:28:39 EDT
*** Bug 478724 has been marked as a duplicate of this bug. ***
Comment 3 Darryl L. Pierce 2009-05-26 16:30:16 EDT
Can we identify about when this pathology first surfaced?

Can we revert rubygem-activeldap back to rubygem-activeldap-1.0.1-1 and see if the caching problem existed then?

Since oVirt is providing only the thinnest veneer over the LDAP code, if there's a caching problem that's shown up after late February (23 February is when rubygem-activeldap-1.0.2-1 was created) then it's likely an upstream bug.
Comment 4 william 2009-05-27 01:17:37 EDT
Darryl

I have tried the latest cvs 27-5-2009 but i can reproduce it anymore.

So i think with the refactoring some things broke but now work again :)

With kind regards

William van de Velde
Comment 5 Mike McGrath 2009-05-27 09:47:07 EDT
Seems to be working now.

Note You need to log in before you can comment on or make changes to this bug.