Bug 496787 - Download progress shows only for first package in list
Download progress shows only for first package in list
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 03:07 EDT by Martin Sourada
Modified: 2010-06-28 08:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update log (21.79 KB, text/plain)
2009-04-21 05:37 EDT, Martin Sourada
no flags Details
update log 2, after first patch (29.97 KB, text/plain)
2009-04-21 06:54 EDT, Martin Sourada
no flags Details

  None (edit)
Description Martin Sourada 2009-04-21 03:07:00 EDT
Description of problem:
The new update applet shows download progress and the downloaded state only for the first package in list, both if yum-presto present and not. It's possible it's a regression caused by the fix for bug 496445. Not sure if the problem is in the gnome front-end or in PackageKit itself, so filling under gnome-packagekit.

Version-Release number of selected component (if applicable):
PackageKit-0.4.6-4.fc11.i586
gnome-packagekit-2.27.2-0.2.20090414git.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Wait till more than one update is available
2. Update via gnome-packagekit
  
Actual results:
Download progress is shown only for the first package in the list, after the download finishes, only the first package in the list is mared as downloaded. Note that if I sort the list under different critieria (e.g. size) the package for which the progress is shown is the one that was first before doing the sort.

Expected results:
Download progress is, in turn, showed for all packages, after the download finishes, all packages are marked as downloaded.

Additional info:
Note that I am currently on really fast connection so the packages are actually downloaded often even in less than a second. I don't know if there are any timeouts in packagekit that might cause it to miss some downloads if they follows too quickly one after another.
Comment 1 Richard Hughes 2009-04-21 03:32:58 EDT
On a quick connection, could you please get the output of:

pkcon --verbose update foo bar

where foo and bar are both package names for updates. I'm stuck on a slow connection here. Thanks.

Richard.
Comment 2 Martin Sourada 2009-04-21 05:37:41 EDT
Created attachment 340490 [details]
update log

Looks like pkcon updates only first package in the argument list, so I run pkcon update without specifying the package instead. Log attached. If I didn't missed something, gnome-bluetooth and gnome-bluetooth-libs were downloaded and updated, but only for gnome-bluetooth-libs the download event was emitted.
Comment 3 Richard Hughes 2009-04-21 06:22:08 EDT
Okay, thanks for that. It appears my previous patch was too fragile -- and the self test cases only exercises the code with a single update :-(

Can you try this build please, and tell me what it does for you:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1310963

Thanks.

Richard.
Comment 4 Martin Sourada 2009-04-21 06:51:31 EDT
(In reply to comment #3)
> Can you try this build please, and tell me what it does for you:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1310963
> 
> Thanks.
> 
> Richard.  
Tested on updating three packages (gthumb, gnome-bluetooth and gnome-bluetooth-libs). The download state is now displayed for all three packages, although the last package has the state Downloading (i.e. not Downloaded) even during testing stage. The other states (updating, clearing) seems to work fine. I'll attach cli output shortly.
Comment 5 Martin Sourada 2009-04-21 06:54:45 EDT
Created attachment 340503 [details]
update log 2, after first patch
Comment 6 Richard Hughes 2009-04-22 07:08:14 EDT
Cool, thanks for that. I've never noticed the downloading rather than downloaded problem before either.

commit 6ed10da156d9130f5443c1348405434cdc0cdfce
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Apr 22 11:55:22 2009 +0100

    yum: send INFO_FINISHED when we've finished downloading a file rather than relying for the daemon to clean up for us. Fixes rh#496787

I'll build rpm's now.

Thanks.
Comment 7 Richard Hughes 2009-04-22 07:16:01 EDT
Can you give these a ago please: http://koji.fedoraproject.org/koji/taskinfo?taskID=1314432

Thanks.
Comment 8 Martin Sourada 2009-04-22 14:58:27 EDT
(In reply to comment #7)
> Can you give these a ago please:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1314432
> 
> Thanks.  

Tested at updating four packages at once. Looks like it works now just as expeted. Thanks for the fix :)
Comment 9 Bug Zapper 2009-06-09 10:16:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2010-04-27 09:50:17 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2010-06-28 08:08:03 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.