Bug 496797 - pidgin not operable in F11
pidgin not operable in F11
Status: CLOSED DUPLICATE of bug 496367
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 04:44 EDT by Joachim Backes
Modified: 2009-04-21 10:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 10:53:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome bugreport after spinning pidgin receives SIGINT (417.37 KB, text/plain)
2009-04-21 08:59 EDT, Bowe Strickland
no flags Details

  None (edit)
Description Joachim Backes 2009-04-21 04:44:13 EDT
Description of problem:
When starting pidgin, it pops up the buddy list and the buddy ticker, then it loops for ever and ever. Then I tried the same loggin in into a new user without a configured pidgin, but it loops too. Un- and re-installing pidgin did not help.

Version-Release number of selected component (if applicable):
pidgin-2.5.5-1.fc11.i586
kernel-2.6.29.1-100.fc11.i586

How reproducible:
Each time I try.

Steps to Reproduce:
1.Start pidgin with an abled account
2.Buddy list and Buddy ticker appear, but they are not sensitive. Pidgin loops in user mode
3.
  
Actual results:
Pidgin loops

Expected results:
Can talk with buddy

Additional info:
Comment 1 Bowe Strickland 2009-04-21 08:59:47 EDT
Created attachment 340515 [details]
gnome bugreport after spinning pidgin receives SIGINT

getting same behaviour, cpu pinned at near 100%, strace on the spinning process implies no system calls, it's stuck in userspace.

ltrace pidgin seems to stalls at the following...

...
g_direct_hash(0x91b0110, 364, 0, 0x83c1a4, 0x708cf7) = 0x91b0110
g_direct_hash(0x91eda20, 0xbc7400, 0, 0x83c1a4, 0x708cf7) = 0x91eda20
g_direct_hash(0x91ac0b8, -1, 0, 0x83c1a4, 0x708cf7) = 0x91ac0b8
g_direct_hash(0x900ecf8, 0x83c928, 0xbf850b28, 0x76f88a, 0x8f6bc88) = 0x900ecf8
<... gtk_window_present resumed> )               = 1
<... purple_blist_set_visible resumed> )         = 0
purple_debug_info(0x810592a, 0x8106da4, 0, 0xca4e9ec1, 0xbf850e78) = 0

but cpu is still pinned at 100%.

after receiving SIGINT, process unfreezes to crash giving more traditional bug 
dialog, bug report attached.
Comment 2 Stu Tomlinson 2009-04-21 10:10:36 EDT
Do you have nautilus-sendto plugin installed and loaded? This could be a duplicate of bug #496367
Comment 3 Joachim Backes 2009-04-21 10:30:31 EDT
Yes.

After removing nautilus-sendto (as described in bug #496367), my problems disappeared too.
Comment 4 Stu Tomlinson 2009-04-21 10:53:32 EDT

*** This bug has been marked as a duplicate of bug 496367 ***

Note You need to log in before you can comment on or make changes to this bug.