Bug 496843 - [RFE] killall5 with -x for excluding processes
Summary: [RFE] killall5 with -x for excluding processes
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: sysvinit (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 496859
TreeView+ depends on / blocked
 
Reported: 2009-04-21 12:56 UTC by Marc Grimme
Modified: 2014-03-17 03:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 14:16:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for killall5/9 to exclude programs from being killed with multiple -x options (3.15 KB, patch)
2009-04-21 12:58 UTC, Marc Grimme
no flags Details | Diff

Description Marc Grimme 2009-04-21 12:56:06 UTC
Description of problem:
When a root filesystem is dependent on userspace programs the halt/reboot process will not work. This happens because killall5/killall9 called by /etc/init.d/halt will kill those programs and might therefore either stop the halt/reboot process or yield other problems.

The attached patches apply to the latest sysvinit sources (killall and init) and add multiple '-x program' options to killall5/killall9.

This is mainly needed when the root filesystem is either a cluster filesystem like gfs/ocfs2/glusterfs or nfs/nfs4.

Version-Release number of selected component (if applicable):
all (fedora,rhel5)

How reproducible:
Always

Steps to Reproduce:
1. Use nfs4/gfs as rootfilesystem and the reboot or halt will kill programs needed for filesystem interaction (aisexec, clvmd, groupd, rpcbind, rpc.idmapd,..)
2.
3.
  
Actual results:
Those programs get killed

Expected results:
Those programs should survive

Additional info:
Goal would be to get it working. First step might be to add -x options to killall5/9
See other bugs for patches to the relevant initscripts.

Comment 1 Marc Grimme 2009-04-21 12:58:26 UTC
Created attachment 340514 [details]
Patch for killall5/9 to exclude programs from being killed with multiple -x options

Comment 2 Bill Nottingham 2009-09-02 20:14:10 UTC
The current rawhide/upstream has -o options to exclude pids; is this 'good enough'? (It would require a separate layer of indirection.)

Comment 3 Marc Grimme 2009-09-03 07:57:16 UTC
If there is a way to fill in pids to killall5 when called by halt/reboot. It is perfectly ok for us.

Is there a way to fill in pids to killall5 when called by the initscripts?

Comment 4 Bill Nottingham 2009-09-03 14:16:37 UTC
Not yet, but we can work on it. I'd just like to avoid adding new things to sysvinit if what's currently there can be made to work. Ergo, closing this request.

Comment 5 Marc Grimme 2009-09-04 13:33:48 UTC
Should I open a new BZ because of the integration of killall5 -o in the initscripts?

Or can we use the Bug (BZ #496859) already open?

Comment 6 Bill Nottingham 2009-09-04 16:45:16 UTC
Existing one is OK.


Note You need to log in before you can comment on or make changes to this bug.