Bug 496859 - [RFE] patch for killall5 with -x for excluding processes in /etc/init.d/halt
[RFE] patch for killall5 with -x for excluding processes in /etc/init.d/halt
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On: 496843
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 09:42 EDT by Marc Grimme
Modified: 2014-03-16 23:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 10:21:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This patch extends /etc/init.d/halt so that all programnames in /etc/xkillall_procs will not being killed (769 bytes, patch)
2009-04-21 09:44 EDT, Marc Grimme
no flags Details | Diff

  None (edit)
Description Marc Grimme 2009-04-21 09:42:13 EDT
Description of problem:
When a root filesystem is dependent on userspace programs the halt/reboot
process will not work. This happens because killall5 called by
/etc/init.d/halt will kill those programs and might therefore either stop the
halt/reboot process or yield other problems.

The attached patches introduces an approach for /etc/init.d/halt to take account of processes being excluded from being killed.

Again a file /etc/xkillall_procs is used to read all processes being excluded from killall5.

This is mainly needed when the root filesystem is either a cluster filesystem
like gfs/ocfs2/glusterfs or nfs/nfs4.

Version-Release number of selected component (if applicable):
all (fedora,rhel5)

How reproducible:
Always

Steps to Reproduce:
1. Use nfs4/gfs as rootfilesystem and the reboot or halt will kill programs
needed for filesystem interaction (aisexec, clvmd, groupd, rpcbind,
rpc.idmapd,..)
2.
3.

Actual results:
Those programs get killed

Expected results:
Those programs should survive

Additional info:
Comment 1 Marc Grimme 2009-04-21 09:44:18 EDT
Created attachment 340525 [details]
This patch extends /etc/init.d/halt so that all programnames in /etc/xkillall_procs will not being killed
Comment 2 Lukáš Nykrýn 2013-03-14 10:21:41 EDT
Initscripts no longer handle this -> close.

Note You need to log in before you can comment on or make changes to this bug.