Bug 497091 - Cannot print with hp laserjet p1005
Cannot print with hp laserjet p1005
Status: CLOSED DUPLICATE of bug 500480
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 06:54 EDT by Enrico Scantamburlo
Modified: 2009-07-13 09:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-13 09:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PPDF file (14.92 KB, text/plain)
2009-04-22 08:01 EDT, Enrico Scantamburlo
no flags Details
The trace of hp I suppose (1.80 MB, text/plain)
2009-04-22 12:42 EDT, Enrico Scantamburlo
no flags Details

  None (edit)
Description Enrico Scantamburlo 2009-04-22 06:54:33 EDT
Description of problem:
Cannot print with hp
if I run dmesg I can see the segmentation fault
eth0: no IPv6 routers present
usb 2-1: new high speed USB device using ehci_hcd and address 2
usb 2-1: New USB device found, idVendor=03f0, idProduct=3d17
usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-1: Product: HP LaserJet P1005
usb 2-1: Manufacturer: Hewlett-Packard
usb 2-1: SerialNumber: BC136D6
usb 2-1: configuration #1 chosen from 1 choice
usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x03F0 pid 0x3D17
usbcore: registered new interface driver usblp
usblp0: removed
hp[6283]: segfault at 14f ip 00000033afe0c231 sp 00007fff119740b0 error 4 in libpthread-2.9.so[33afe00000+17000]
usb 2-1: USB disconnect, address 2

tried with different versions of cups

Version-Release number of selected component (if applicable):
[enrico@localhost ~]$ rpm -qa | grep hp
rhpxl-1.9-3.fc10.x86_64
hplip-libs-2.8.12-6.fc10.x86_64
hplip-2.8.12-6.fc10.x86_64
rhpl-0.218-1.x86_64
hpijs-2.8.12-6.fc10.x86_64
[enrico@localhost ~]$ rpm -qa | grep cups
cups-1.3.10-1.fc10.x86_64
cupsddk-drivers-1.2.3-5.fc10.x86_64
hal-cups-utils-0.6.19-1.fc10.x86_64
cups-libs-1.3.10-1.fc10.x86_64
bluez-cups-4.30-2.fc10.x86_64
libgnomecups-0.2.3-4.fc10.x86_64
cups-libs-1.3.9-8.fc10.i386
cups-devel-1.3.10-1.fc10.x86_64


How reproducible:
Try to print with a laserjet p1005 and run dmesg

Steps to Reproduce:
1.
2.
3.
  
Actual results:
the printer becomes disabled

Expected results:
the printer prints


Additional info:
Comment 1 Tim Waugh 2009-04-22 07:20:59 EDT
Please attach the PPD for the queue (from the /etc/cups/ppd/ directory).
Comment 2 Enrico Scantamburlo 2009-04-22 08:01:24 EDT
Created attachment 340720 [details]
PPDF file
Comment 3 Enrico Scantamburlo 2009-04-22 08:01:57 EDT
Added the attachment
Comment 4 Tim Waugh 2009-04-22 10:20:33 EDT
Please try these packages:

http://koji.fedoraproject.org/koji/buildinfo?buildID=99133

Download them and use 'rpm -Fvh hplip*.rpm hpijs*.rpm libsane-hpaio*.rpm' to install them.

Does the problem still occur?  If so please look in /var/log/messages to see if there are any error messages that occur around the time of the fault.
Comment 5 Enrico Scantamburlo 2009-04-22 11:00:46 EDT
Apr 22 16:56:19 localhost hal_lpadmin: Added printer HP-LaserJet-P1005
Apr 22 16:56:24 localhost kernel: usblp0: removed
Apr 22 16:56:24 localhost hpijs: unable to open PrintContext object err=48
Apr 22 16:56:29 localhost HP_LaserJet_P1005?serial=BC136D6: io/hpmud/hpmud.c 608: invalid channel_write state
Comment 6 Enrico Scantamburlo 2009-04-22 11:01:33 EDT
thanks for the fast fix but it does still not work, see log
Comment 7 Tim Waugh 2009-04-22 11:43:51 EDT
Does 'dmesg' still show a segfault from the 'hp' process?
Comment 8 Enrico Scantamburlo 2009-04-22 11:46:48 EDT
yes

hp[3972]: segfault at 33af20af48 ip 00000033afe0c26b sp 00007fffefcc6460 error 7 in libpthread-2.9.so[33afe00000+17000]
Comment 9 Tim Waugh 2009-04-22 11:59:29 EDT
Next step is to look a little closer at what the hp backend is up to.  Please install the strace package (yum install strace) and do this, as root:

set $(ps ax|grep [c]upsd)
strace -fp $1 2>cupsd.txt

and then print a page as normal.  Once it has failed, press control-C to stop the strace program, and attach the cupsd.txt file to this bug report.  Thanks.
Comment 10 Enrico Scantamburlo 2009-04-22 12:42:56 EDT
Created attachment 340769 [details]
The trace of hp I suppose

done
Comment 11 Tim Waugh 2009-04-27 09:29:36 EDT
More investigation required but fixing component to be a source package.
Comment 12 vaeood 2009-05-08 15:11:50 EDT
I have installed Fedora 10 i686 on my desktop and I have exactly the same problem with HP LaserJet P1005. I have installed hplip and hpijs and a lot of other things. The troubleshooter advises me to reconsider the settings of the system firewall. Do you think this would help, and do you have any idea what to change in the firewall?!
Comment 13 vaeood 2009-05-14 01:08:42 EDT
Thank you for the assistance. I managed to install the printer driver at last, and it is printing with the speed of light in vacuum. I uninstalled from the Package Installer the three packages of HPLIP for F10. After that downloaded hplip-3.9.4b.run directly from the site of HP and run it:

        $ cd ~/Desktop
Desktop $ cd ~/Download
Download$ sh hplip-3.9.4b.run

The monster of the printers under Linux proved to be a binary driver plug-in. For further details write <binary driver plug-in> in Google and look at the results.
Comment 14 Tim Waugh 2009-07-13 09:15:16 EDT
I'm going to mark this as a duplicate of bug #500480, as basically the problem boils down to 'can't get HP LJ P1005 to work'.

Yes, a binary plug-in is required for hplip to drive this printer.  If you want a printer that can be driven by free software alone, you need to choose another printer. :-(

*** This bug has been marked as a duplicate of bug 500480 ***

Note You need to log in before you can comment on or make changes to this bug.