Bug 500480 - HP LaserJet P1005 isn't plug'n'play; configuration requires expert guidance
HP LaserJet P1005 isn't plug'n'play; configuration requires expert guidance
Status: CLOSED DUPLICATE of bug 531330
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 497091 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 16:49 EDT by Mads Kiilerich
Modified: 2009-11-09 08:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-09 08:19:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2009-05-12 16:49:13 EDT
Description of problem:

I have a use case / user story which obviously should work, and that it doesn't is in my opinion a bug: When attaching a HP LaserJet P1005 USB printer then the plug'n'play system should work and just make the printer work.

My experience was that a printer was created, but it didn't work and print jobs just disappeared without any usable hints in /var/log.

It turns out that the essential part that was missing was that I had to run hp-setup and let it download the driver and configure the printer. So I guess that my request is that hp-setup should be run automatically.

I file this issue on cups because I know that cups is a very central component of Fedora printing. The problem might however have to be solved somewhere else.


Version-Release number of selected component (if applicable):

cups-1.4-0.b2.16.fc11.i586
hplip-3.9.2-4.fc11.i586
DeviceKit-003-1.i586
Comment 1 Tim Waugh 2009-05-15 08:54:36 EDT
The essential part is in fact a proprietary plugin for HPLIP.

There is no entirely free driver for the P1005.  HPLIP requires a proprietary plugin, and foo2xqx seems like it might contain patented algorithms.

With Fedora, which has deep roots in free software, automatically downloading proprietary parts is not something we want to do.
Comment 2 Mads Kiilerich 2009-05-15 09:35:51 EDT
Ok, thanks for the facts. I thought HPLIP downloaded firmware. But hplip _is_ in Fedora, and thus I expect it to be fully supported and integrated and plug'n'play.

A clear indication (message or log) that "this printer is not supported" or "no driver found" would be an OK (but sad) resolution. But obviusly it would be better if users were helped to make it work.

FWIW foo2xqx from Some Other Repo did not work for me. But if that is the way to go then I assume that could be solved.

I don't see foo2xqx on http://fedoraproject.org/wiki/ForbiddenItems or anywhere else in bz - has Legal looked at it and made a final verdict?
Comment 3 Bug Zapper 2009-06-09 11:43:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tim Waugh 2009-07-13 09:15:16 EDT
*** Bug 497091 has been marked as a duplicate of this bug. ***
Comment 5 Tim Waugh 2009-11-09 08:19:39 EST
This is resolved by the fix for bug #531330 in conjunction with the fix for bug #531872.

*** This bug has been marked as a duplicate of bug 531330 ***

Note You need to log in before you can comment on or make changes to this bug.