Bug 497111 - amanda subpackages require only a specific version of amanda, not also release
amanda subpackages require only a specific version of amanda, not also release
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: amanda (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Novotny
BaseOS QE
:
Depends On:
Blocks: 497488
  Show dependency treegraph
 
Reported: 2009-04-22 08:40 EDT by Radek Bíba
Modified: 2009-09-02 05:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 497488 (view as bug list)
Environment:
Last Closed: 2009-09-02 05:48:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2009-04-22 08:40:28 EDT
Description of problem:
If no specific release is required, which is the case of amanda-devel, -server and -client subpackages, rpm won't complain if a user tries to update only the base package, or just a subset of subpackages. This can lead to inconsistencies in installed packages and malfunction caused by incompatibility.

Please replace all occurrences of "Requires(pre): amanda = %{version}" with "Requires(pre): amanda = %{version}-%{release}".

Version-Release number of selected component (if applicable):
amanda-2.5.0p2-4
Comment 2 Daniel Novotny 2009-04-24 05:19:40 EDT
fixed in amanda-2.5.0p2-6.el5
Comment 6 errata-xmlrpc 2009-09-02 05:48:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1300.html

Note You need to log in before you can comment on or make changes to this bug.