This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 497131 - svirt fails to relabel qcow2 backing files
svirt fails to relabel qcow2 backing files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
: 525362 (view as bug list)
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-04-22 09:41 EDT by Mark McLoughlin
Modified: 2009-10-02 11:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-02 11:23:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-04-22 09:41:38 EDT
If you create a qcow2 image with a backing file:

  $> qemu-img create -b f11-beta.qcow2 -f qcow2 f11-beta.snap1.qcow2

and configure a domain to use it:

    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/var/lib/libvirt/images/f11-beta.snap2.qcow2'/>
      <target dev='hda' bus='ide'/>
    </disk>

and start it:

  $>  virsh start f11-beta
  error: Failed to start domain f11-beta
  error: internal error unable to start guest: qemu: could not open disk image /var/lib/libvirt/images/f11-beta.snap2.qcow2

type=AVC msg=audit(1240410685.659:86): avc:  denied  { read } for  pid=9537 comm="qemu-kvm" name="f11-beta.qcow2" dev=dm-0 ino=3466427 scontext=system_u:system_r:svirt_t:s0:c280,c287 tcontext=system_u:object_r:virt_image_t:s0 tclass=file

The problem is obvious - we're re-labelling the qcow2 image, but not its backing file.

Note, the backing file should be read-only for all guests which use a qcow2 image backed by it.
Comment 1 Bug Zapper 2009-06-09 10:24:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Mark McLoughlin 2009-09-24 03:25:04 EDT
*** Bug 525362 has been marked as a duplicate of this bug. ***
Comment 3 Mark McLoughlin 2009-09-25 09:31:07 EDT
Patches posted upstream for this:

  http://www.redhat.com/archives/libvir-list/2009-September/msg00740.html

It's fairly invasive so, while I'll backport it to F12, I won't be backporting it to F11.
Comment 4 Mark McLoughlin 2009-10-01 11:19:17 EDT
Okay, I've backported this to F-12 and will build it later today

* Thu Oct  1 2009 Mark McLoughlin <markmc@redhat.com> - 0.7.1-8
- Re-label qcow2 backing files (#497131)

Patch is http://gitorious.org/~markmc/libvirt/fedora/commit/5bb2da190b
Comment 5 Mark McLoughlin 2009-10-02 11:23:05 EDT
This is in rawhide now

Note You need to log in before you can comment on or make changes to this bug.