This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 525362 - VM cannot boot from the backing disk img
VM cannot boot from the backing disk img
Status: CLOSED DUPLICATE of bug 497131
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-23 23:28 EDT by jbao
Modified: 2009-09-24 03:25 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-24 03:25:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jbao 2009-09-23 23:28:45 EDT
Description of problem:

I have a kvm-guest machine using the qcow2 format image and it works fine.
Now I want to creat a new image to take the place of this old image,use the old disk image as as a readonly 'backing store'.

I run the command "virsh vol-create default new.xml" with the following new.xml:
<volume>
  <name>new.img</name>
  <capacity>1000000000</capacity>
  <allocation>0</allocation>
  <target>
    <format type='qcow2'/>
  </target>
  <backingStore>
    <path>/var/lib/libvirt/images/myoriginal.img</path>
  </backingStore>
</volume>

And then I repoint this kvm-guest to the new disk image,but can't the start the guest with the error " internal error unable to start guest: qemu: could not open disk image /var/lib/libvirt/images/new1.img "

By the way, the command "virsh vol-create --pool default new.xml"  in the Test_Day:2009-09-17_Virtualization_qcow2 doesn't work with the error "'vol-create' need <file> option",so I remove --pool and it works.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.virsh vol-create default new.xml
2.virsh edit myguest_name,repoint the disk image to the new one
3.start the guest.
  
Actual results:
Can not start the guest with the error "internal error unable to start guest: qemu: could not open disk image /var/lib/libvirt/images/new1.img "

Expected results:
Can start the guest

Additional info:
Comment 1 CAI Qian 2009-09-24 01:41:04 EDT
Jerry, can you provide the related software versions and how reproducible of this issue?
Comment 2 jbao 2009-09-24 02:21:47 EDT
the related software version as follow:
libvirt-0.7.1-4.fc12.x86_64
qemu-kvm-0.10.92-4.fc12.x86_64
Comment 3 Mark McLoughlin 2009-09-24 03:25:04 EDT
Thanks for the report

I'm pretty sure this is bug #497131

Try again after 'setenforce 0' - if it still doesn't work, then please re-open

*** This bug has been marked as a duplicate of bug 497131 ***

Note You need to log in before you can comment on or make changes to this bug.