This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 497183 - Installation fails with partition scheme
Installation fails with partition scheme
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 497189 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 13:38 EDT by A.J. Werkman
Modified: 2009-05-29 11:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 11:02:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Tty3 screenprint (645.52 KB, image/gif)
2009-04-22 13:38 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2009-04-22 13:38:38 EDT
Created attachment 340776 [details]
Tty3 screenprint

Description of problem:
Anaconda fails installing rawhide when a certain partitioning scheme is already on the harddisks

Version-Release number of selected component (if applicable):
Anaconda 11.5.0.46

How reproducible:
Everytime

Steps to Reproduce:
I start with a system that has the following partitioning on the disks:

  Device  Start    End     Blocks   Id  System
/dev/sda1     1    130    1044193+  83  Linux

/dev/sdb1     1  24792  199141708+  8e  Linux LVM

I do a installation booting with pxe and boot parameters "text nomodeset".

After formatting is complete the following error occurs:
An error occurered mounting device /dev/sda1 as /boot: mount failed: (2, None). This is a fatal error and the install cannot continue.

On tty2 I can see that anaconda has altered the partitioning scheme. 

In attach a screen print from tty3.
Comment 1 Chris Lumens 2009-04-22 15:16:47 EDT
*** Bug 497189 has been marked as a duplicate of this bug. ***
Comment 2 A.J. Werkman 2009-05-04 06:31:31 EDT
With anaconda-11.5.0.48 I still get this error, but after every installation run anaconda adds an extra boot partition on drive /dev/sda although I asked to "replace existing linux system".

When I wipe out the LVM partition on /dev/sdb this error does not occure.
Comment 3 Chris Lumens 2009-05-29 11:02:02 EDT
We had a variety of (2, None) related bugs during this release cycle but I believe they are all solved by now.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.