Bug 497264 - powerpc: rawhide install installer kernel.ppc not kernel.ppc64 on 64-bit host.
powerpc: rawhide install installer kernel.ppc not kernel.ppc64 on 64-bit host.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 497569 (view as bug list)
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-04-23 00:32 EDT by Tony Breeds
Modified: 2009-05-19 18:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 13:14:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-logs.tgz (42.65 KB, application/octet-stream)
2009-04-28 09:25 EDT, James Laska
no flags Details

  None (edit)
Description Tony Breeds 2009-04-23 00:32:27 EDT
An install of today's rawhide resulted in a successful install but the boot failed.  This is tracked down to the fact that we have a 32-bit kernel on my 64-bit host.


Version-Release number of selected component (if applicable):


ec009356d579aec8d6d3ff4e9622cc9a  ramdisk.image.gz
0a6bbf4604cdd87a50022af9903b7ea4  vmlinuz
3e32dbf4e0f0cf6dcceeac263dafe193  yaboot
$ strings vmlinuz | egrep '^Linux version'
Linux version 2.6.29.1-102.fc11.ppc64 (mockbuild@ppc6.fedora.phx.redhat.com) (gcc version 4.4.0 20090414 (Red Hat 4.4.0-0.34) (GCC) ) #1 SMP Mon Apr 20 15:22:57 EDT 2009

http://download.fedora.redhat.com/pub/fedora/linux/development/ppc/os/images/install.img
(There is no http://download.fedora.redhat.com/pub/fedora/linux/development/ppc64/os/images/install.img)
I don't know what version of anacondathis is but:
$ strings -n 5 install.img | head
200904221244.ppc
Fedora
development
https://bugzilla.redhat.com

How reproducible:

I netbooted the yaboot, kernel and initrd above, ran through the installer (getting install.img from the URL above).  The machine failed to boot.  Installing the kernel.ppc64 package (and removeing the kernel.ppc package) fixes the problem.
Comment 1 Chris Lumens 2009-04-24 15:06:54 EDT
*** Bug 497569 has been marked as a duplicate of this bug. ***
Comment 2 James Laska 2009-04-28 09:25:15 EDT
Created attachment 341570 [details]
anaconda-logs.tgz

Attaching installer log files

-rw-r--r-- root/root    131503 2009-04-28 08:55 tmp/anaconda.log
-rw-r--r-- root/root     12620 2009-04-28 08:55 tmp/program.log
-rw-r--r-- root/root    209254 2009-04-28 08:55 tmp/storage.log
-rw-r--r-- root/root     30410 2009-04-28 08:45 tmp/syslog
-rwxr-xr-x root/root       857 2009-04-28 08:22 tmp/vncserver.log
-rw-r--r-- root/root     23371 2009-04-28 08:55 mnt/sysimage/root/install.log
-rw-r--r-- root/root      3290 2009-04-28 08:47 mnt/sysimage/root/install.log.syslog
Comment 3 Chris Lumens 2009-04-28 13:14:04 EDT
This will be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 4 Geoff Levand 2009-05-19 18:56:30 EDT
Just to follow up, I tested this on a Mac G5 with today's rawhide build (19-May-2009 09:08) and this problem if fixed.

-Geoff

Note You need to log in before you can comment on or make changes to this bug.