This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 497569 - anaconda installs 32 bit kernel on 64 bit Mac G5
anaconda installs 32 bit kernel on 64 bit Mac G5
Status: CLOSED DUPLICATE of bug 497264
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 15:02 EDT by Geoff Levand
Modified: 2009-04-24 15:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 15:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Geoff Levand 2009-04-24 15:02:03 EDT
Description of problem:

anaconda installs the 32 bit kernel package on the 64 bit Mac G5.
I noticed bootup started failing several days ago, but just now investigated it.

Version-Release number of selected component (if applicable):

anaconda-11.5.0.47
today's rawhide build (24-Apr-2009 10:02)

sha1sum ppc/os/ppc/ppc64/{ramdisk.image.gz,vmlinuz}
384cf8ac27a26070cb2de3f908ce8cfa2a59fabb  ppc/os/ppc/ppc64/ramdisk.image.gz
d9e172912488fc456a25b7066faa74e121d13aa9  ppc/os/ppc/ppc64/vmlinuz

How reproducible:

100%

Steps to Reproduce:
1. run install
2. do 'ls /mnt/sysroot/boot/'
3. reboot
  
Actual results:

Shows /mnt/sysroot/boot/vmlinux-**-f11.ppc.smp
Gets OpenFirmware fault on startup.

Expected results:

Should show /mnt/sysroot/boot/vmlinux-**-f11.ppc64

Additional info:

Tried text and graphical install on the Mac G5 with same failure.

The correct kernel (64 bit) is installed on the PS3 game console.

-Geoff
Comment 1 Chris Lumens 2009-04-24 15:06:54 EDT

*** This bug has been marked as a duplicate of bug 497264 ***

Note You need to log in before you can comment on or make changes to this bug.