This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 497290 - Updating kernel does not update grub
Updating kernel does not update grub
Status: CLOSED DUPLICATE of bug 124246
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 04:43 EDT by Phil
Modified: 2009-12-26 08:12 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 03:07:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phil 2009-04-23 04:43:47 EDT
Description of problem:
every single kernel update i do does not update grub.  this issue persists through complete reinstalls.

Version-Release number of selected component (if applicable):
F11 rawhide

How reproducible:
without fail - or with fail depending on where you stand :).

Steps to Reproduce:
1. install x86_64 system
2. update kernel
3. inspect /boot/grub/grub.conf
  
Actual results:
additional kernel line has not been added to grub.conf

Expected results:
new kernel be listed to easily boot in to.

Additional info:
i can still boot the system to the new kernel by either manually updating grub.conf or using the grub command line.... ugh!

is this related to the system-config-boot issue?? bug #473798
Comment 1 Chuck Ebbert 2009-04-23 15:15:06 EDT
what happens if you manually run the new-kernel-pkg command?  e.g.

 new-kernel-pkg --depmod --install 2.6.29.1-102.fc11.x86_64
Comment 2 Dave Jones 2009-04-23 15:53:59 EDT
the only time I saw something like this, /etc/grub.conf was a broken symlink, which caused /sbin/grubby to go nuts.
Comment 3 Phil 2009-04-23 17:33:58 EDT
Symlink's fine:
lrwxrwxrwx. 1 root root     11 2009-04-19 23:14 menu.lst -> ./grub.conf


[root@x64 grub]# new-kernel-pkg -v --depmod --install 2.6.29.1-102.fc11.x86_64
initrdfile is /boot/initrd-2.6.29.1-102.fc11.x86_64.img
running depmod for 2.6.29.1-102.fc11.x86_64
found /boot/initrd-2.6.29.1-102.fc11.x86_64.img and using it with grubby
adding 2.6.29.1-102.fc11.x86_64 to /boot/grub/grub.conf
grubby fatal error: unable to find a suitable template
/etc/lilo.conf does not exist, not running grubby
Comment 4 Dave Jones 2009-04-23 18:30:37 EDT
LILO !?!#@$!

reassigning to mkinitrd (the package which provides grubby)
Comment 5 Hans de Goede 2009-04-24 03:07:23 EDT
I'm afraid this is a known unknown (as in we don't know the cause) issue, marking this as a dup of the original bug.

Is there perhaps anything weird with your grub.conf ? Try copying over a grub.conf from another machine and do minimal editing to make it match the
machine in question. That might help. If that helps it would be nice if you could piecemeal warp the new grub.conf into the non working one to find out what breaks grubby.

*** This bug has been marked as a duplicate of bug 124246 ***

Note You need to log in before you can comment on or make changes to this bug.