Bug 497409 - Scribus freezes at start-up
Scribus freezes at start-up
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: scribus (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 15:16 EDT by Paul Black
Modified: 2009-05-22 14:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.3.5-0.12.beta.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 23:57:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Black 2009-04-23 15:16:56 EDT
Description of problem:
scribus freezes when loading scriptplugin at splash screen

Version-Release number of selected component (if applicable):
scribus-1.3.5-0.5.12516svn.fc10.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. splash screen freezes at Plugin:loading scriptplugin
2.
3.
  
Actual results:
Freezes

Expected results:
Should run

Additional info:
Symptoms look very similar to bug 492011.
Comment 1 Fedora Update System 2009-04-24 11:43:24 EDT
scribus-1.3.5-0.12.beta.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/scribus-1.3.5-0.12.beta.fc10
Comment 2 Paul Black 2009-04-26 02:04:14 EDT
That now works for me.

Cheers.
Comment 3 Fedora Update System 2009-04-27 17:20:58 EDT
scribus-1.3.5-0.12.beta.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scribus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3921
Comment 4 Bill McGonigle 2009-05-04 10:53:34 EDT
I can confirm that the current version is definitely unusable and that 1.3.5-0.12.beta.fc10 works.

aside: yum didn't find it for me, one of the mirrors may be lagging, but installing the package from koji was easy enough (click through the admin. link above).
Comment 5 Kieran Clancy 2009-05-09 06:59:09 EDT
There is a workaround:

When it hangs, run gdb on it, run a 'bt', change the frame to the one which says initPlugin (ie 'frame 20') and then return ('ret'). Then detach and quit gdb. You may need some of the debuginfo packages.
Comment 6 Martin Donald 2009-05-09 23:15:02 EDT
The fix 
su -c 'yum --enablerepo=updates-testing update scribus'
works for me

Linux localhost.localdomain 2.6.27.21-170.2.56.fc10.x86_64 #1 SMP Mon Mar 23 23:08:10 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Thanks.
Comment 7 Fedora Update System 2009-05-11 23:57:45 EDT
scribus-1.3.5-0.12.beta.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 SP 2009-05-22 12:56:56 EDT
I am running Fedora 10 Kernel 2.6.27.21-170.2.57.fc10.i686 and Gnome 2.24.3
I have Scribus 1.3.5.  The last time I used the program was March 22 09 and everything worked fine.  Today, May 22 09 it stalls on loading scriptplugins (as above).  So I am presuming that one of the many system upgrades must have broken the program.  I'll try the beta.
Comment 9 SP 2009-05-22 14:50:25 EDT
The 1.3.5.beta works fine.  Note to travellers to this page ...  Rather than use the instructions in Comment #6 - it is better to do the following:
1. Open 'Add Remove Software' under the Administration menu
2.  Search 'Scribus'
3.  Remove Scribus 1.3.5 (if you have it installed)
4. The beta will now be available
5. Install the latest beta, header files and documentation

Note You need to log in before you can comment on or make changes to this bug.