Bug 497437 - Luci server global name error
Luci server global name error
Status: CLOSED DUPLICATE of bug 458298
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
4.6
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 17:20 EDT by adam
Modified: 2009-04-30 11:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 11:57:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam 2009-04-23 17:20:49 EDT
Description of problem:
When trying to create a new cluster from the Luci server, an error stating "global name 'os' is not defined".  Note: The system is actually running Scientific Linux Cern which is built off of RHE4.6, the versions of Luci/Ricci used are those released by Red Hat.  

Version-Release number of selected component (if applicable):
Name   : luci
Arch   : x86_64
Version: 0.11.1
Release: 5.el4
Size   : 164 M
Repo   : installed
Summary: Remote Management System - Management Station

How reproducible:
After installing Luci and changing the iptables to enable the ports defined by the Conga documentation for 4.6; start up the luci server (/sbin/service luci start) and setup an administrator password (luci_admin init).  In a web-browser go to the page listed by the luci server.  Click on the cluster tab and then the create new cluster.  Type in a cluster name, and the name of at least 1 server to be added, then submit.  The cluster is not created instead a 'Site Error' occurs, stopping the operation. The error details are:
Error Type: Name Error
Error Value: global name 'os' is not defined
Error Date: <current date and time>

Steps to Reproduce:
1.Start a new luci server, in a web browser go to the site listed (server.domain:8084).
2.Login, click on the 'cluster' tab, click on 'create a new cluster' 
3.Enter a name for the cluster along with at least one valid node name & password, then click submit.
  
Actual results:
A 'Site error' occurs, stopping the operation. Error details are:
Error Type: Name Error
Error Value: global name 'os' is not defined
Error Date: <current date and time>

Expected results:
The cluster is created.

Additional info:
The bug seems to be browser independent (occurs on IE7,FireFox3,Konquerer). I recognize the error text from python, possibly a script forgot to 'import os'?
Comment 1 Ryan McCabe 2009-04-30 11:57:56 EDT

*** This bug has been marked as a duplicate of bug 458298 ***

Note You need to log in before you can comment on or make changes to this bug.