Bug 497482 - Can not unzip files > 2GB
Can not unzip files > 2GB
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: unzip (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Michal Luscon
qe-baseos-daemons
:
: 596291 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 02:40 EDT by Frank Deng
Modified: 2013-03-14 12:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 11:55:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patched unzip-5.52-near-4GB.patch (1.52 KB, patch)
2011-09-14 11:31 EDT, Vojtech Vitek
no flags Details | Diff
unzip-5.52-near-4GB3.patch (843 bytes, patch)
2011-09-14 11:32 EDT, Vojtech Vitek
no flags Details | Diff
unzip-5.52-near-4GB4-types.patch (4.72 KB, patch)
2011-09-14 11:32 EDT, Vojtech Vitek
no flags Details | Diff

  None (edit)
Description Frank Deng 2009-04-24 02:40:53 EDT
Description of problem:
Only on X86 box, Can not unzip files > 2GB

Version-Release number of selected component (if applicable):
RHEL 5.2 X86

How reproducible:

Steps to Reproduce:
1. create a zip file size > 2GB
2. unzip the file

  
Actual results:

Error:
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.


Expected results:
unzip successfully.

Additional info:

The bug has been fixed in RHEL4, see bug 199104
Comment 1 Robin Laing 2009-12-19 16:26:56 EST
According to http://www.info-zip.org/UnZip.html, the latest version for unzip is 6.0 and was released 2009-April-20.  

From the site.
----
Latest Release

New features in UnZip 6.0, released 20 April 2009:

    * Support PKWARE ZIP64 extensions, allowing Zip archives and Zip archive entries larger than 4 GiBytes and more than 65536 entries within a single Zip archive. This support is currently only available for Unix, OpenVMS and Win32/Win64
---

I was just about to post a bug/RFE to get the latest version of unzip into Fedora as well.  I need to unzip an archive that is bigger than 4Gig.


I see that there is a version of unzip in Fedora 11's update testing that is still 5.52 based. 

I have downloaded the sources and tested version 6.0 against a dual-layer DVD ISO image.  8209104896 bytes in size.
Comment 4 RHEL Product and Program Management 2010-08-09 14:21:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-01-11 14:57:47 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-12 10:15:57 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 8 RHEL Product and Program Management 2011-05-31 09:10:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 Vojtech Vitek 2011-09-07 13:33:20 EDT
I still can't reproduce the issue..

$ dd if=/dev/zero of=big bs=1024k count=3600
$ zip -5 big.zip big
$ rm big
$ unzip-5.52/unzip big.zip
Archive:  big.zip
  inflating: big
$ echo $?
0
$ du -h big*
3.6G    big
3.5M    big.zip
$ unzip-5.52/unzip -l big.zip 
Archive:  big.zip
  Length     Date   Time    Name
 --------    ----   ----    ----
3774873600  09-07-11 12:51   big
 --------                   -------
3774873600                   1 file

The patches in RHEL-4 are are very different from the patches in RHEL-5, partly because of newer upstream version (unzip 5.51 vs. unzip 5.52).
Comment 10 Vojtech Vitek 2011-09-07 17:08:54 EDT
Can you please test the testing/unsupported packages from
http://people.redhat.com/vvitek/unzip-5.52-3.0.bz497482.el5_7/
and let me know if it fixes the >2GB problem?

Thanks!
Comment 11 Vojtech Vitek 2011-09-12 10:50:48 EDT
The bug should be fixed in the testing/unsupported packages provided in comment 10.

Can anyone confirm that by testing the packages, or by providing any previously-failing reproducer? Thanks!
Comment 12 Vojtech Vitek 2011-09-14 11:31:21 EDT
Created attachment 523179 [details]
Patched unzip-5.52-near-4GB.patch
Comment 13 Vojtech Vitek 2011-09-14 11:32:02 EDT
Created attachment 523180 [details]
unzip-5.52-near-4GB3.patch
Comment 14 Vojtech Vitek 2011-09-14 11:32:26 EDT
Created attachment 523181 [details]
unzip-5.52-near-4GB4-types.patch
Comment 15 Jamie 2011-09-20 12:19:45 EDT
I have a 16 GB file that is producing this problem:

unzip file.zip 
error:  Zip file too big (greater than 4294959102 bytes)
Archive:  file.zip
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of file.zip or
        file.zip.zip, and cannot find file.zip.ZIP, period.

This error is produced with the unsupported package from comment 10. It is possible that this specific zip file is corrupt in some other way considering the last part of that message "cannot find zipfile directory..."
Comment 16 Jamie 2011-09-20 12:47:39 EDT
(In reply to comment #15)
> I have a 16 GB file that is producing this problem:
> 
> unzip file.zip 
> error:  Zip file too big (greater than 4294959102 bytes)
> Archive:  file.zip
>   End-of-central-directory signature not found.  Either this file is not
>   a zipfile, or it constitutes one disk of a multi-part archive.  In the
>   latter case the central directory and zipfile comment will be found on
>   the last disk(s) of this archive.
> unzip:  cannot find zipfile directory in one of file.zip or
>         file.zip.zip, and cannot find file.zip.ZIP, period.
> 
> This error is produced with the unsupported package from comment 10. It is
> possible that this specific zip file is corrupt in some other way considering
> the last part of that message "cannot find zipfile directory..."

Never mind, I apologise for posting prematurely. The zip file in question seems to have some other problem other than being large.
Comment 17 Vojtech Vitek 2011-09-21 17:54:30 EDT
(In reply to comment #16)
> Never mind, I apologise for posting prematurely. The zip file in question seems
> to have some other problem other than being large.

Anyway, thanks for your help!
Comment 18 Vojtech Vitek 2011-09-26 17:07:08 EDT
Frank (and others involved), can you please test the unsupported package provided in comment 10 and confirm if it fixes the issue for you? Thanks!
Comment 19 Vojtech Vitek 2012-03-07 11:14:46 EST
*** Bug 596291 has been marked as a duplicate of this bug. ***
Comment 22 RHEL Product and Program Management 2012-06-11 21:02:51 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 23 Michal Luscon 2013-03-14 12:12:25 EDT
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first
production phase 2 [1] release of RHEL-5. Since phase 2 we'll be
addressing only security and critical issues.
This one issue is fixed in RHEL-6 therefore I am closing the bug as
NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.