Bug 596291 - unzip command fails while unzipping file from NFS mounted filesystem
unzip command fails while unzipping file from NFS mounted filesystem
Status: CLOSED DUPLICATE of bug 497482
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: unzip (Show other bugs)
5.5
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Vojtech Vitek
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 10:31 EDT by rajesh bhatt
Modified: 2015-03-04 18:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 11:14:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rajesh bhatt 2010-05-26 10:31:58 EDT
Description of problem:
unzip process fails when trying to unzip files more than 2GB in size.


Version-Release number of selected component (if applicable):
Linux 2.6.9-42.0.10.ELsmp #1 SMP Fri Feb 16 17:13:42 EST 2007 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
While unzipping file more than 2 GB in size.


Steps to Reproduce:
1. unzip 90231135_20100524_20100524.zip 
2. this unzip file contents following files
->unzip -l 90231135_20100524_20100524.zip
--------    ----   ----    ----
385780713  05-25-10 04:34   1.txt
309133610  05-25-10 04:34   2.txt
  8237477  05-25-10 04:35   3.txt
2156880349  05-25-10 04:35   Page.txt
 64938678  05-25-10 04:39   Prod.txt
  7513556  05-25-10 04:39   Reg1.txt
  3670572  05-25-10 04:39   Reg2.txt
130085257  05-25-10 04:39   Sht3.txt
106268779  05-25-10 04:39   Techpro.txt
 11170988  05-25-10 04:39   FILE.txt
 --------                   -------
3183679979                   10 files

the unzip process fails while inflating Page.txt file with following error:

unzip_test->unzip 90231135_20100524_20100524.zip

Archive:  90231135_20100524_20100524.zip
  inflating: 1.txt
  inflating: 2.txt
  inflating: 3.txt
  inflating: Page.txt
Page.txt:  write error (disk full?).  Continue? (y/n/^C)y 
bad CRC 803dd6df  (should be aa69c875)
  inflating: Prod.txt
  inflating: Reg1.txt
  inflating: Reg2.txt
  inflating: Sht3.txt
  inflating: Techpro.txt
  inflating: FILE.txt

3. checking the results
-rw-r--r--  1 batchid datawhse  385780713 May 25 04:34 1.txt
-rw-r--r--  1 batchid datawhse  309133610 May 25 04:34 2.txt
-rw-r--r--  1 batchid datawhse    8237477 May 25 04:35 3.txt
-rw-r--r--  1 batchid datawhse 2147483647 May 25 04:35 Page.txt
-rw-r--r--  1 batchid datawhse   64938678 May 25 04:39 Prod.txt
-rw-r--r--  1 batchid datawhse    7513556 May 25 04:39 Reg1.txt
-rw-r--r--  1 batchid datawhse  130085257 May 25 04:39 Sht3.txt
-rw-r--r--  1 batchid datawhse    3670572 May 25 04:39 Reg2.txt
-rw-r--r--  1 batchid datawhse  106268779 May 25 04:39 Techpro.txt
-rw-r--r--  1 batchid datawhse   11170988 May 25 04:39 FILE.txt
-rwxr-xr-x  1 batchid datawhse  624094929 May 26 10:19 90231135_20100524_20100524.zip
  
Actual results:

The Page.txt file size is: 2147483647 

Expected results:

The Page.txt actual size is : 2156880349  

Additional info:

The process also fails for different file set. The zipped files are mounted on NFS shared drive. 

Coping the files to local mount also produces same results as described in the 'steps to reproduce'.
Comment 1 RHEL Product and Program Management 2011-05-31 10:15:02 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 2 Vojtech Vitek 2012-03-07 11:14:46 EST

*** This bug has been marked as a duplicate of bug 497482 ***

Note You need to log in before you can comment on or make changes to this bug.