Bug 497643 - xsane 100% cpu loop, no gui
xsane 100% cpu loop, no gui
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-25 10:12 EDT by Tom Horsley
Modified: 2009-05-05 05:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 21:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug session from attach to hung xsane (33.52 KB, text/plain)
2009-04-25 10:37 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2009-04-25 10:12:15 EDT
Description of problem:

I run xsane, the initial dialog to select which image device comes up, and
has my HP photosmart all-in-one already selected as the default. I click OK,
the initial dialog goes away, xsane goes into a 100% cpu loop, and the preview
app never appears. The scanner device is:

hpaio:/usb/Photosmart_C5500_series?serial=MY8AFC20JZ056H
Hewlett-Packard Photosmart_C5500_series all-in-one

Same hardware works fine with fedora 10 xsane.

Also the command line scanimage tool seems to work just fine on this device
even in rawhide.

Version-Release number of selected component (if applicable):
xsane-0.996-6.fc11.x86_64

How reproducible:
every time

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
infinite loop

Expected results:
scanner app

Additional info:
Comment 1 Tom Horsley 2009-04-25 10:37:08 EDT
Created attachment 341317 [details]
debug session from attach to hung xsane

I downloaded some debuginfo files, attached to xsane, and found it searching
for the end of a linked list in which list->next apparently points to list,
so finding the end of that will take a while :-). The backtrace looks like
it is fiddling with gtk menus when it gets into this loop.
Comment 2 Walter Harris 2009-04-27 23:32:37 EDT
I am having the same problem:
FC11 Beta x86_64 with Rawhide updates
xsane          x86_64          0.996-6.fc11     
Intel Core i7
Scanner: Brother MFC-240C all-in-one
Symptom: Initial "Scanning for devices..." dialog appears, then disappears.  Nothing follows.  Xsane is then running in the background at high CPU with no windows visible.

Alternatives:
The command line tool "scanimage" makes the scanner begin scanning apparently normally.  (I interrupted it at that point.)

I downgraded to the xsane RPM xsane-0.996-3.fc10.x86_64.rpm from Fedora 10 and the problem went away.  The scanning windows appear normally and I can scan an image.
Comment 3 Warren Togami 2009-05-04 04:51:55 EDT
http://kojipkgs.fedoraproject.org/packages/xsane/0.996/7.fc11/
Please try this build.  It made xsane work for me.

If it works for you, then this is the same bug as Bug #493659.
Comment 4 Adam Batkin 2009-05-04 16:16:23 EDT
I can confirm the exact same behaviour as the original report, but with an HP PSC 1310. The updated packages (xsane-0.996-7) indeed solve that issue for me.
Comment 5 Tom Horsley 2009-05-04 18:14:25 EDT
Me too. I just installed the x86_64 rpms from the above link and it works
fine. I'm looking at a preview image now.

Note You need to log in before you can comment on or make changes to this bug.