Bug 497668 - F11 Disk Partitioning is inconsistent
F11 Disk Partitioning is inconsistent
Status: CLOSED DUPLICATE of bug 490922
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-25 18:36 EDT by Richard G Thomson
Modified: 2009-04-27 10:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 10:20:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard G Thomson 2009-04-25 18:36:16 EDT
Description of problem:

The graphical disk partitioning with the Live CDs (install to hard drive) and the full DVD install create partitions that are not on a cylinder boundary.  The ending cylinder of one partition is the same as the beginning partition of the next.  "fdisk -l" complains that the partition is not on a cylinder boundary.


Version-Release number of selected component (if applicable):  Live KDE, Live XFCE, and DVD of FC11 Beta



How reproducible:  Results are consistent with a number of installs on both SATA and IDE drives, VIA and Intel processors.


Steps to Reproduce:
1.  Select either default or custom partitioning.
2.  Run fdisk -l or sfdisk and observe the results.
3.
 


Expected results:  All other installs (FC6-FC10) behave consistently.  For example, the boot partition goes from 1-25, the / partition from 26-whatever.


Additional info:

Here's output from uname -a and fdisk -l on one of the tests:

Linux localhost.localdomain 2.6.29-0.258.2.3.rc8.git2.fc11.i586 #1 SMP Tue Mar 24 18:37:23 EDT 2009 i686 i686 i386 GNU/Linux

Disk /dev/sda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0008b390

Device Boot Start End Blocks Id System
/dev/sda1 * 1 26 204800 83 Linux
Partition 1 does not end on cylinder boundary.
Comment 1 Richard G Thomson 2009-04-25 18:37:59 EDT
I've posted to fedoraforum.org and linuxquestions.org with no responses.
Comment 2 Chris Lumens 2009-04-27 10:20:53 EDT

*** This bug has been marked as a duplicate of bug 490922 ***

Note You need to log in before you can comment on or make changes to this bug.